Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 20 of 20
erm there is no such dir as /usr/local/var/ Urgh, error stuff came from /var/lib/mysql in there I have a mysql folder with all the table files for databases. New error ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Mar 2005
    Location
    London, UK
    Posts
    8

    erm there is no such dir as /usr/local/var/

    Urgh, error stuff came from /var/lib/mysql

    in there I have a mysql folder with all the table files for databases.

    New error in the file:

    050303 23:00:39 mysqld started
    050303 23:00:40 InnoDB: Started
    050303 23:00:40 /usr/libexec/mysqld: Can't find file: './mysql/host.frm' (errno: 13)
    050303 23:00:40 Fatal error: Can't open privilege tables: Can't find file: './mysql/host.frm' (errno: 13)
    050303 23:00:40 Aborting

    050303 23:00:40 InnoDB: Starting shutdown...
    050303 23:00:42 InnoDB: Shutdown completed
    050303 23:00:42 /usr/libexec/mysqld: Shutdown Complete

    050303 23:00:42 mysqld ended
    But, there is host.frm......

  2. #12
    Just Joined!
    Join Date
    Mar 2005
    Posts
    12
    Quote Originally Posted by nisan
    omegadot: The point being I can't start it, meaning I can't edit it.
    That's why I said after you install it, was just a little tip.

  3. #13
    Just Joined!
    Join Date
    Mar 2005
    Location
    London, UK
    Posts
    8
    woohoo I fixed it.....By re-installing it

    I downloaded it off the web and just removed all traces of mysql and the groups etc through the console...or shell....or whatever you call it.

    Anyway thanks for helping

  4. #14
    Just Joined!
    Join Date
    Mar 2005
    Posts
    6
    Slackware comes with mysql the problem is that you have to initilze the permission tables as someone else said. But they were off by just a little bit, you needed to do the following

    mysql_install_db --user=mysql


    The reason for the user part is because the mysql daemon runs as the user mysql, and if you leave that off the privalges tables are all created and owned by root instead of the user mysql which means that it will not be able to read/save the files. However you can fix it by running

    chown mysql:users /var/lib/mysql/* -R

    I know you said you have it working but I just wanted to let you know anyway for furture reference.

  5. #15
    Just Joined!
    Join Date
    Mar 2005
    Location
    London, UK
    Posts
    8
    ok thanks.

    My new thing, how do I make it start/stop at boot/shutdown?

    I know I have to put mysql.server in /etc/init.d, and I've done that, then I apparently have to link it to /etc/rc3.d/S99mysql and /etc/rc0.d/K01mysql. How do I link?

  6. #16
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    Code:
    ln -s /etc/init.d/mysql.server /etc/rc3.d/S99mysql
    ln -s /etc/init.d/mysql.server /etc/rc3.d/K01mysql
    Should do the trick

  7. #17
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    On a second thought,
    is Slackware using this directory structure?
    It's been a while since I installed a Slackware, I do have an old version yet running though. And I know for fact that my running version does not use this directory structure.
    Someone with more experience with the newer versions of slackware might help out here

  8. #18
    Just Joined!
    Join Date
    Mar 2005
    Location
    London, UK
    Posts
    8
    I worked out how to do the linking 1 minute after my last post :/

    And no, structures aren't the same, more like /etc/rc.d/rc0.d/blaaaah and etc/rc.d/rc3.d/ffflfkdfkdjd

    Thanks again for your help everyone, now I have to do php

  9. #19
    Just Joined!
    Join Date
    Mar 2005
    Posts
    6
    I have no clue what you were talking about to get it to start up, but if you installed slackware 10.1 its very easy to do. Just make sure /etc/rc.d/rc.mysqld is executable

    chmod +x /etc/rcd/rc.mysqld

    As long as that file exists thats all you should have to do. Since you reinstaleld mysql you might want to edit that file and make sure it is running the correct mysqld deamon.

    As for getting php to work just edit /etc/apache/httpd.conf search for the line

    Include /etc/apache/mod_php.conf

    and make sure it is uncommented and then restart apache

    /etc/rc.d/rc.httpd restart

    and you should be all set. If you need to make changes to the php setting just edit the php.ini of mod_php.conf file and you should find what you need in them. Also by default apahce looks for a file called index.html and displays it when users request just a directory like www.mysite.com/test/
    If you want it to look for index.php as well you will need to edit /etc/apache/httpd.conf and find the following lines

    <IfModule mod_dir.c>
    DirectoryIndex index.html
    </IfModule>

    Add on to the end of that line for what other default files you want it to use, the order does matter because that is the order it checks for the files in. So if your line looks like

    DirectoryIndex index.html index.php

    If you have both and index.html and an index.php file in there it will use the index.html file since it is first on the line.

  10. #20
    Just Joined!
    Join Date
    Mar 2005
    Posts
    2
    I am running into similar problems i have gone through the first two pages and i get this error

    Code:
    root@ServerBox&#58;/usr/bin# Starting mysqld daemon with databases from /var/lib/mysql
    STOPPING server from pid file /var/run/mysql/mysql.pid
    050328 17&#58;15&#58;01  mysqld ended
    When i try to fix it with

    Code:
    root@ServerBox&#58;/usr/bin# mysql_install_db --user=mysql
    I get

    Code:
    Neither host 'ServerBox' nor 'localhost' could not be looked up with
    /hw13/d06/accountname/mysql/bin/resolveip
    Please configure the 'hostname' command to return a correct hostname.
    If you want to solve this at a later stage, restart this script with
    the --force option
    Please understand i'm fairly new to linux and i'm a moron.

    when i try --force i still get the same issue. I have tried looking for /hw13/ the file i can't find it.

    I used the help of this site http://www.washington.edu/computing/...l-install.html

    I didn't know if that folder was spedific to what i used from that site. because i did make the /.my.cnf file but i can't find it any longer.
    i Know i prlly screwed things up royally but can you guys help.
    if there is anything else i can get you to help me plz post here or email here cooperjoshua@gmail.com or AIM me at Chumpzor i'll check back regulary thanks very much in advance.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •