Hello,

I've just installed Slackware 10.1. Two things surprised me. Neither my modem or sound card were detected, though both worked in Slack 9.1. I can work around the sound issue, until (or if) I find a solution, but internet access is essential. Anyway, I followed the steps provided here:

http://www.linuxquestions.org/quest...1+modem+is+busy

This at least got the system to see my modem (my thanks to the author). Using KPPP, I configured my modem on ttyS3, not ttyS4 as I had initially set it up during installation. When I queried the modem, the system recognized it and responded something like this:

TI: 5601
ATI 1: C084
ATI 2: OK
ATI 3: U.S. Robotics 56K FAX INT V5.22.70
ATI 4: U.S. Robotics 56K FAX INT Settings... B0 E0 F1 L0 M0 Q1 V1 X4 Y0
BAUD=115200 PARITY=N WORDLEN=8 DIAL=TONE ON HOOK CID=0
&A3 &B1 &C1 &D2 &G0 &H1 &I0 &K1 &M4 &N0 &P1 &R2 &S0
&T5 &U0 &Y1 S00=000
ATI 5: U.S. Robotics 56K FAX INT NVRAM Settings... Template Y0 DIAL=TONE
B0 E1 F1 L1 M1 Q0 V1 X4 BAUD=115200 PARITY=N WORDLEN=8
&A3 &B1 &C1 &D2 &G0 &H1 &I0 &K1 &M4 &N0 &P1 &R2 &S0
&T5 &U0 &Y1 S00=000 S02=
ATI 6: Template Y1 DIAL=TONE B0 E1 F1 L1 M1 Q0 V1 X4
BAUD=115200 PARITY=N WORDLEN=8 &A3 &B1 &C1 &D2 &G0
&H2 &I2 &K1 &M4 &N0 &P1 &R1 &S0 &T5 &U0 &Y1 S00=000
S02=043 S03=013 S04=010 S05=008 S06=004 S07=
ATI 7: Configuration Profile... Product type US/Canada Internal Product ID:
00561002 Options V32bis,V.80,V.34+,V.90,V.92 Fax Options
Class 1/Class 2.0 Line Options Caller ID, Distinctive Ring Clo

(I copied that from the aforementioned article, but my output wasn't too different.)

I tried to dial out and was told that the modem was busy. I checked /dev/modem and saw that it was linked to /dev/ttyS4. I rm-ed /dev/modem and linked /dev/ttyS3 to a new /dev/modem. I'm still getting the "modem is busy" message, whether I try to query the modem or dial out.

My modem is a 3Com/US Robotics 5610. I'm running Slack 10.1 on a 900 Meg Celeron with 128 MB RAM.

Any assistance would be greatly appreciated.