Find the answer to your Linux question:
Results 1 to 5 of 5
alright well this is pretty much my third post on the same thing. well i still cant connect using a cable at my home, but i was wardriving this weekend ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    98

    Network connection problems


    alright well this is pretty much my third post on the same thing. well i still cant connect using a cable at my home, but i was wardriving this weekend and it connected using my wireless card, and then i can connect using a cable at my school, so i was just wandering if someone could think of anything else using this info (im running slackware 10)

  2. #2
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    I'm not sure but it sounds like your ethernet card is configured because it works at school. Try looking around and changing settings in this file:

    /etc/conf.d/net

    look at it using the less comand for example: less /etc/conf.d/net
    and edit it with something like nano: nano /etc/conf.d/net

    look to see it it is set to automatically obtain ip with dhcp

    find out how your internet service works. Does it use dhcp or do you need to manually assign ip values?

    besides that it sounds like a perplexing problem.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  3. #3
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    This is slackware, so no conf.d

    The settings of ethernet devices are in /etc/rc.d/rc.inet1.conf . After modifying your changes (using netconf or netconfig, I don't remember) you could restart the thing using
    Code:
    /etc/rc.d/rc.inet1 start
    I\'m so tired .....
    #200472

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2005
    Posts
    98
    well i do have dhcp so there is nothing really to configure, but i did try netconfig and it didn't help anything

  6. #5
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    Maybe give us some more info. It is weird that the wireless dhcps and your school dhcp's. I would look to make sure your not using a crossover cable at your house. Maybe at your house write a shell script using a static IP to see if that works.

    Here is something I do.
    cd /etc/rc.d/
    cp rc.inet1.conf rc.inet1.conf.dhcp
    cp rc.inet1.conf rc.inet1.conf.home
    pico rc.inet1.conf.home
    edit it with a static. (assuming your network is 192.168.1.)
    Pick an IP that isn't in your router dhcp pool usually 192.168.1.5 works fine.
    then make your subnet mask 255.255.255.0
    then where is says
    dhcp "yes" change it to dhcp ""
    then scroll down to gate way and make it
    192.168.1.1 # if that is your network
    then save it
    Now write a shell script

    call it net.home
    pico net.home
    Code:
    cd /etc/rc.d
    cp rc.inet1.conf.home rc.inet1.conf
    reboot
    save in root home directory.
    So when you go home
    log in as root and do this
    Code:
    ./net.home
    Then it will reboot again but the IP will be static.
    something you can try.
    You could write another script to change it back
    cp inet1.conf.dhcp rc.inet1.conf
    save it

    another thing I do is make a backup of the rc.inet1 file because when you start playing with the rc.inet1.conf file if your forget the .conf you is overwrite your rc.inet1 file and that would be bad so I make a copy like this
    cp rc.inet1 rc.inet.orig
    then you have a backup in case you make a mistake.

    I hope this works for you.
    Let me know if you need more clarrification
    Mike
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •