Find the answer to your Linux question:
Results 1 to 9 of 9
I have been using linux(Slackware 10) on and off for the past year and now I suddenly got interested again when i started working on php, apache and mysql...i do ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    6

    Some questions that need answers... (,")


    I have been using linux(Slackware 10) on and off for the past year and now I suddenly got interested again when i started working on php, apache and mysql...i do have certain questions that i always wanted to be answered and here they are:

    1. how do you add a shutdown/reboot option in KDE, i only see a logoff button?
    2. how do you autostart kde?
    3. I have problems with my sound card(C-Media AC97 Audio Device), no sound at all, how do i configure it or at least get a driver for it?
    4. I have a HP PSC 1310, all-in-one...where could i get a driver for it?


  2. #2
    Linux Newbie
    Join Date
    Jan 2005
    Posts
    157
    This site lists that printer as "mostly supported". That probably means you can print but maybe not scan, not sure though..
    Click the specific printer listing for more on that printer and for recommended driver..
    If (exoskeleton || (green && wiggles)) eat_it();

  3. #3
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    your default runlevel for slackware is 3, console mode, you need to reset to either 4 or 5, different distros use different settings; however, if anything ever happens to your x settings you will have some work to do. Its much better to log in to console and type "startx", which will make it much easier to fix any future problems.

    run
    Code:
    alsamixer
    to manually unmute all of your sound options, default in linux is muted so you have to manually unmute, them
    Code:
    alsactl store
    in order to save your settings upon reboot. so try this and then see if you have sound, slack is good about hardware detection and many times when you think that the card is not installed or has no driver it is just still default muted.
    Operating System: GNU Emacs

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Oct 2004
    Location
    Serbia&Montenegro
    Posts
    281
    In Slackware, default runlevel is 3. To start up in X change it to 4. So you should do this:

    Code:
    id:3:initdefault:
    change to:

    Code:
    id:4:initdefault:
    Linux registered user #358842
    Human knowledge belongs to the world.

  6. #5
    Just Joined!
    Join Date
    Mar 2005
    Posts
    6
    very interesting...k, about the startx thing...i remembered long b4 that i did change a setting in the /etc/rd something and i couldn't log-in to slack...i was looking for another way to get into the regular startup but i couldn't do it so i just reinstalled slack... ...anyway, i read in the manual for slack that i have to chmod something...kinda lost in this one since i tried what was said in the manual and still couldn't make it work...oh, btw, thanx for all the help...my pc's currently in another place and i might try all this by next week...i'll keep you guys posted...thnx...

  7. #6
    Just Joined!
    Join Date
    Mar 2005
    Posts
    6
    hello guys, so i took a day-off from work (yeeeey!!!) and did what you guys wanted me to do...so i did the
    Code:
    alsamixer
    thing and guess what, slack said it couldn't find my sound card...
    Code:
    alsamixer:function snd_ctl_open failed for default: No Such Device
    darn, thought i could finally make my sound card work...did that in school and everything was fine...guess the sound card wasn't detected at all by slack...and then the modem thing...installed the modem driver from cd yet it didn't work...lots of mumbo jumbo things that i couldn't understand...the drivers were from conexant, pct1889 drivers with instructions on how to install it...i knew that it wasn't installed the day i ran
    Code:
    pppsetup
    then did the
    Code:
    ppp-go
    now, if i could only get slack online, get my sound card working then i could start configuring LAMP...hope you guys don't mind me whining ...it's just so hard to get things done in linux...and i guess that's where the fun is (the reason why i got so interested in linux anyway)... need all the help i could get...

  8. #7
    Just Joined!
    Join Date
    Apr 2005
    Posts
    7
    (Wewt first post)
    hey linuxguruwannabe, to get your sound card working follow these steps.

    1) download the most recent "alsa-drivers" from the alsa site
    found near the bottom of here: ftp://ftp.alsa-project.org/pub/driver/
    2) in a terminal type "alsaconf" and follow the step (as root).
    3) then use alsamixer to umute everything (using the up arrows)
    4)hit escape
    5) type alsactl store (again as root).
    then get some music on the go to test it give us a link to your modem driver how to and i'll have a blast at it, see if i can make any sense of it.

    peace out,
    gizm0

  9. #8
    Just Joined!
    Join Date
    Mar 2005
    Posts
    6
    uhmmm, i wanted to try that one but i have this recurring problem ever since i started using linux...i just could not get it connected...i have a hsp56 modem and i guess i'll just follow some threads for these one but could you recommed a link to a thread that actually solved this problem?

    thanx again guys...

  10. #9
    Linux Newbie
    Join Date
    Jan 2005
    Posts
    157
    Sorry LinuxGuruWannaBe.. thought you were on your way by now..
    I found this post. The modem is discussed down near the bottom of the page..
    has its' own heading..
    hope it helps..

    Try this.
    This one you'll need to search on "Linux" from edit menu as most of it is windows.
    If (exoskeleton || (green && wiggles)) eat_it();

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •