Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13
is your router also acting as a dns server?...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035

    is your router also acting as a dns server?

  2. #12
    Just Joined!
    Join Date
    Apr 2005
    Posts
    6
    Hi,

    Yes I think my routers DNS is the same IP as the DHCP 192.168.0.1 this is according to WinXP: ipconfig /all

    Something really starnge is happening now, I have finally got my NIC recognized and the light on the router was showing a link but now the light has started to go out again after flashing for a while. If I do: ifconfig eth0 up it doesn't complain about no device being found, it just returns me to the prompt again.

    As I type this the link light on the router is out. I tried pinging google again but got a message: connect: Network is unreachable.

    I just don't understand it, I could ping google before and since then I haven't changed anything, only rebooted a couple of times. I tried pinging 192.168.0.3 which is my eth0 NIC but got 100% packet loss.

    I have tried also turning UPnP off in the web interface of my router just incase this was causing trouble, I've turned Zone Alarm Pro off in Windows incase it was stopping the router from giving my NIC it's IP.

    Thanks for your help, I'm really at a loss of what to try next.

    Thanks again

  3. #13
    Just Joined!
    Join Date
    Apr 2005
    Posts
    1

    possible solution

    well, i think i may have found the answer, or a workaround for your problem. yesterday was the first time EVER in myh life i used linux so i'm not sure if my solution is the prettiest, but it works.

    i installed slackware 10.1 on an old compact server i got (128 ram, scsi hdds, etc). i had a series of problems, but the last on being i didn't know how to configure the built in NIC. then i saw netconfig on this tread. i configured it for DHCP, it detected the NIC all all seemed well. but then i still couldn't get online. but ifconfig told me that my NIC was getting an IP assigned. on another machine i pinged google to find its IP, and used the IP in the address, and bam, it worked. okay, DNS problem. but DHCP should have taken care of this.

    so what i did to make it work was went back to netconfig, setup DHCP, and under the DHCP name server, i used the address of the router (actually at first i used 4.2.2.1, but i wouldn't want to rely on an outside source for this). and all is well in slackware country now. i'm still not sure if this was the best solution, but for an utter, 150% newie, it will do. let me know if this helps.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •