Find the answer to your Linux question:
Results 1 to 8 of 8
Heya guys, I'm having a few problems with getting my sound to work since I upgraded from slackware 9.1 to 10.1, with 9.1 it detected my sound card straight away ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    7

    slackware 10.1 and problems with sound? =/


    Heya guys, I'm having a few problems with getting my sound to work since I upgraded from slackware 9.1 to 10.1, with 9.1 it detected my sound card straight away and I ran alsaconf and alsamixer turned up the volume everything was fine. Things are abit weird now though, The sound appears to play in xmms although on start up I get

    Code:
    libmikmod.so.2: cannot open shared object file: No such file or directory

    I've also tried playing an avi in xine which plays with no sound aswell.

    So far I've
    1) ran alsaconfig
    2) ran alsamixer
    3) umuted the volume using the up arrows
    4) ran alsactl store
    which found my card apparently as
    "intel8x0 Silicon Intergrated Systems [SiS] Sound Controller (rev a0)".

    which didn't seem to make any difference.

    the I
    5) downloaded the latest alsa-driver ./configure'd and did make && make install on it, which completed successful.
    6) re ran alsaconfig, same card detected.
    7) re ran alsamixer to check volume, which was the same as before.

    all with no luck, so I tried to change the settings in xmms from the Oss driver to the alsa output plugin and tried to replay the mp3, still with no luck

    lspci reports
    Code:
    00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)



    i'm not exactly 100% sure what the sound card is, but all I know is, I had no problems with a fresh install of slackware 9.1.

    if anyone can help even get slightly closer to fixing this problem, I will be grateful,

    thanks,

    gizm0

  2. #2
    Linux User Krendoshazin's Avatar
    Join Date
    Feb 2005
    Location
    London, England
    Posts
    471

    Re: slackware 10.1 and problems with sound? =/

    Quote Originally Posted by mr.gizm0
    which found my card apparently as "intel8x0 Silicon Intergrated Systems [SiS] Sound Controller (rev a0)".
    try checking /etc/hotplug/blacklist and see if snd-intel8x0m is blacklisted, if it is, remove it and try
    Code:
    modprobe snd-intel8x0m
    see if this does the trick

  3. #3
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058

    Re: slackware 10.1 and problems with sound? =/

    Quote Originally Posted by Krendoshazin
    Quote Originally Posted by mr.gizm0
    which found my card apparently as "intel8x0 Silicon Intergrated Systems [SiS] Sound Controller (rev a0)".
    try checking /etc/hotplug/blacklist and see if snd-intel8x0m is blacklisted, if it is, remove it and try
    Code:
    modprobe snd-intel8x0m
    see if this does the trick
    Don't want to step on any toes here but I wanted to interject something
    On my lappy snd-intel8x0m is my modem and snd-intel8x0 is my sound card and to get my sound to work i had to add snd-intel8x0m to my blacklist and modprobe snd-intel8x0
    I hope this works for you.

    Mike

    also see if you can mess with the setting in kmix
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User Krendoshazin's Avatar
    Join Date
    Feb 2005
    Location
    London, England
    Posts
    471

    Re: slackware 10.1 and problems with sound? =/

    Quote Originally Posted by adrenaline
    Don't want to step on any toes here but I wanted to interject something On my lappy snd-intel8x0m is my modem and snd-intel8x0 is my sound card and to get my sound to work i had to add snd-intel8x0m to my blacklist and modprobe snd-intel8x0
    I hope this works for you.

    Mike

    also see if you can mess with the setting in kmix
    that's probably what it is, i only remembered that an intel 8x0 sound device had been added to the blacklist as shown on the current changelog

  6. #5
    Just Joined!
    Join Date
    Apr 2005
    Posts
    7
    hey guys, thanks for your replies, sorry I only just got back to this, i've been really really really busy with work.

    I'll try it out when i get home, thanks again

    gizm0

  7. #6
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    The answer to the first part of your question is to install a package:
    http://slackware.com/pb/showdesc.php...-3.1.10-i486-3

  8. #7
    Just Joined!
    Join Date
    Sep 2006
    Posts
    1
    I'm having a similar problem. Everytime i boot my computer up, the sound isn't working. I have to open up the konsole and use alsaconf to get the sound working again. How do I set it to where it will automatically start when it's booted. Thanks.

  9. #8
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    you dont need to install that package, its just an input/output plugin

    you'll notice if you start XMMS from the command line it'll complain that it can't load whatever audio decoding libraries you dont have installed, but it'll work fine.

    its just saying the mikmod library is installed, but this in no way means you have to install it to fix xmms.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •