Find the answer to your Linux question:
Results 1 to 5 of 5
So, I've got ALSA support (with emu10k1) included in my running kernel. And indeed, alsaconf recognizes my SoundBlaster Audigy card as being supported by emu10k1. So when I run alsaconf, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246

    ALSA emu10k1 troubles


    So, I've got ALSA support (with emu10k1) included in my running kernel. And indeed, alsaconf recognizes my SoundBlaster Audigy card as being supported by emu10k1. So when I run alsaconf, I am presented with this menu:

    Code:
    ------- Soundcard Selection -------
    Following card(s) are found on your system.
    Choose a soundcard to configure:
    -----------------------------------------------------------------
    emu10k1   Creative Labs SB Audigy (rev 04)
    legacy    Probe legacy ISA (non-PnP) chips
    Of course, I choose the first option, and the configurator finishes without complaint, even recommending that I have lots of fun. However, sound still only comes out of my onboard (NVidia CK8S) soundcard, whose sound quality is non-negligibly crappy. Alsamixer also reports that the soundcard being used is my onboard card. Any ideas?

    Possibly useful output:
    Code:
    # lsmod | grep snd
    snd_emu10k1            89960  -
    snd_util_mem            3080  -
    snd_hwdep               6628  -
    Situations arise because of the weather,
    And no kinds of love are better than others.

  2. #2
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    I don't think this is the exact solution you want, but can you turn off the onboard sound in the bios?
    Brilliant Mediocrity - Making Failure Look Good

  3. #3
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246
    Yes, but that's not the problem -- I want to make sound come out of my SoundBlaster card, and no sound is coming out of it.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Quote Originally Posted by dan@george
    Yes, but that's not the problem -- I want to make sound come out of my SoundBlaster card, and no sound is coming out of it.
    we understand that, it just could be your onboard sound messing up the sound system and thus nothing comes out of the card, so disabling the onboard sound in the BIOS is worth a shot.

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  6. #5
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246
    Oh, okay. Yeah, disabling the onboard soundcard in the BIOS worked. I'm sorry for ever doubting you.

    Thanks a lot!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •