Find the answer to your Linux question:
Results 1 to 5 of 5
Every time I reboot, aumix sets my all volume settings back to zero and I have to reload my settings. How do I make it so that my settings load ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    45

    aumix resets sound settings on reboot


    Every time I reboot, aumix sets my all volume settings back to zero and I have to reload my settings. How do I make it so that my settings load on boot?

    thanks,
    mr.popper[/code]

  2. #2
    Linux User Krendoshazin's Avatar
    Join Date
    Feb 2005
    Location
    London, England
    Posts
    471
    after you've set the mixer to the required levels, make sure you're a superuser and use the command
    Code:
    alsactl store

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Location
    Oklahoma
    Posts
    38
    I had the same issue; even with the alsa settings stored I still had to set the volumes with aumix. What you can do is run aumix as root set the levels, save the settings and add
    Code:
    aumix -L
    to your /etc/rc.d/rc.local file. It looks ugly at bootup, but your volume levels will be set.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Jul 2004
    Location
    Calcutta, India
    Posts
    220
    Maybe you dont have these 2 lines at the end of your /etc/modules.conf :
    post-install snd-card-0 /usr/sbin/alsactl restore >/dev/null 2>&1 || :
    pre-remove snd-card-0 /usr/sbin/alsactl store >/dev/null 2>&1 || :

  6. #5
    Linux User Krendoshazin's Avatar
    Join Date
    Feb 2005
    Location
    London, England
    Posts
    471
    the settings get restored by /etc/rc.d/rc.alsa which is executed by /etc/rc.d/rc.M, it should set this up automatically when you run alsaconf, if you still find you don't have the script you can get it here
    rc.alsa
    Code:
    load_alsa_mixer() {
      if [ -r /etc/asound.state ]; then
        echo "Loading ALSA mixer settings:  /usr/sbin/alsactl restore"
        /usr/sbin/alsactl restore
      else
        echo "ALSA warning:  No mixer settings found in /etc/asound.state."
        echo "  Sound may be muted.  Use 'alsamixer' to unmute your sound card,"
        echo "  and then 'alsactl store' to save the default ALSA mixer settings"
        echo "  to be loaded at boot."
      fi
    }
    also make sure that /etc/rc.d/rc.M has this line in it
    Code:
    if [ -x /etc/rc.d/rc.alsa ]; then
      . /etc/rc.d/rc.alsa
    fi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •