Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I bought today new keyboard / mice combination, it uses usb -port Ok, keyboard works fine. But mouse doens't Checked dmesg dmesg | grep mouse root@scourge:/home/ville# dmesg | grep ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    70

    Keyboard mouse -combination problems


    Hi, I bought today new keyboard / mice combination, it uses usb -port
    Ok, keyboard works fine.

    But mouse doens't
    Checked dmesg
    dmesg | grep mouse

    root@scourge:/home/ville# dmesg | grep mouse
    usb.c: registered new driver usbmouse
    usbmouse.c: v1.6:USB HID Boot Protocol mouse driver
    mice: PS/2 mouse device common for all mice

    and tryed to look with cat /dev/input/mouse
    cat /dev/input/mouse0
    cat /dev/input/mice

    and so on, and mouse doens't start to work.

    Tryed diffrent protocols, like ImPS/2, Auto, ExplorerPS/2.
    My kernel is 2.4.29, it came with Slackware 10.1

    Option "Protocol" "Auto"
    # Option "Device" "/dev/input/mouse0"
    # Option "Device" "/dev/psaux"
    Option "ZAxisMapping" "4 5"
    # Option "Device" "/dev/ttyS0"
    # Option "Device" "/dev/ttyS1"


    root@scourge:/home/ville# dmesg | grep mouse
    usb.c: registered new driver usbmouse
    usbmouse.c: v1.6:USB HID Boot Protocol mouse driver
    mice: PS/2 mouse device common for all mice

    lsmod
    usbmouse 1880 0 (unused)
    usbkbd 2936 0 (unused)
    usb-ohci 19368 0 (unused)
    usbcore 58860 1 [hid usbmouse usbkbd usb-ohci ehci-hcd)
    hid 20804 0 (unused)

    Oh yea, and the keyboard mouse are Logitech Cordless Desktop Deluxe
    I think..

    If i forgotted something, please let me know.

  2. #2
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    Code:
    add:
    Option "Device" "/dev/input/mice"
    Change:
    Option "Protocol" "IMPS/2"
    Try these changes in your xorg.conf. It should work

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    70
    Quote Originally Posted by puntmuts
    Code:
    add:
    Option "Device" "/dev/input/mice"
    Change:
    Option "Protocol" "IMPS/2"
    Try these changes in your xorg.conf. It should work
    Tryed, tryed also ExplorerPS/2

    and I'm sorry that I forgot that rule about double posting.
    I would delete this one (becouse the other one may be in better place)
    but I checked and couldn't.
    Maybe moderator will delete the otherone..

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •