Find the answer to your Linux question:
Results 1 to 9 of 9
This is a very basic question, but I'm confused on how to unpackage a .tgz, without Slackware packaging tools (Because that's exactly what I'm trying to unpackage) So, it's a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    12

    Installing Packaging Tools


    This is a very basic question, but I'm confused on how to unpackage a .tgz, without Slackware packaging tools (Because that's exactly what I'm trying to unpackage)

    So, it's a .tgz file and I tried 'tar -zvxf <pkg>.tgz' and it unpacks, of course, but not to the right place. How do I untar is so it doesn't just create usr, bin, sbin, etc directories in whatever directory I happen to be in? What command options do I use so it untars to where it's SUPPOSED to go?

    I know this question is idiotically simple, but I can't seem to find the answer in the man pages or after much searching online.

    EDIT: Also, while I'm on the subject...I tried going to the / directory and untarring it, but it still didn't work. I mean, it untarred, but the package tools weren't installed. How can I undo the tar, just in case I overwrote files/messed something up? Somethings tells me this isn't possible.

    Thanks in advance,
    ~morawski

  2. #2
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Buenos Aires, Argentina
    Posts
    908
    You're not supossed to uncompress the .tgz package and compile it...

    installpkg packagename.tgz
    serzsite.com.ar
    "All the drugs in this world won\'t save you from yourself"

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    12
    Let me clarify: I don't have the packaging tools for Slackware, such as installpkg, removepkg, updatepkg, makepkg, explodepkg. The .tgz file I am trying to untar contains these tools.
    ~morawski

  4. #4
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    It is just a normal tarbal, so you can unpack it with tar -xzvf <archivename>. After that you could use the newly unpacked pkgtools to install the package again.

  5. #5
    Linux User Krendoshazin's Avatar
    Join Date
    Feb 2005
    Location
    London, England
    Posts
    471
    why do you not have those tools, did you try running them as a superuser? if you run them as a normal user it'll just says "command not found"

  6. #6
    Just Joined!
    Join Date
    Mar 2005
    Location
    Oklahoma
    Posts
    38
    Hmm... I don't see how you got Slackware without the pkgtools either, BUT, you could always get the pkgtools source from your favorite Slackware mirror and install them that way.

  7. #7
    Linux Newbie
    Join Date
    Feb 2005
    Posts
    181
    Or you could just put the installation disc in and only install that package at setup. Just dont format any partitions on accident.

  8. #8
    Just Joined!
    Join Date
    May 2005
    Posts
    12
    I wasn't sure why I didn't have the package tools either...now I know, I DID have the package tools, afterall.

    Wasn't aware you had to have root priveledges

    Well, you learn something new everyday..and with Linux this is an understatement.

    Thanks for putting up with me, all,
    ~morawski

  9. #9
    Just Joined!
    Join Date
    Jan 2005
    Posts
    70
    If you don't have pkgtool installed.
    Go to slackware.com
    Packages
    And select 10.1 / current (depends do you want stable or "unstable)

    (Both can work fine)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •