Find the answer to your Linux question:
Results 1 to 6 of 6
I realize this issue is more of a mysql issue but I wanted to ask here as well in case someone had run into this before. In a nutshell, I'm ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    6

    mysql/linux question


    I realize this issue is more of a mysql issue but I wanted to ask here as well in case someone had run into this before.

    In a nutshell, I'm trying to upgrade my old mysql 4.0.16 to the newest 4.1 version. When I go to extract the .rpm file, no matter where I extract it at I am getting this:

    error: failed dependencies:
    /bin/sh is needed by MySQL-server-4.1.11-0.glibc23
    /bin/sh is needed by MySQL-server-4.1.11-0.glibc23
    /bin/sh is needed by MySQL-server-4.1.11-0.glibc23
    /bin/sh is needed by MySQL-server-4.1.11-0.glibc23
    /usr/bin/perl is needed by MySQL-server-4.1.11-0.glibc23
    fileutils is needed by MySQL-server-4.1.11-0.glibc23
    libc.so.6()(64bit) is needed by MySQL-server-4.1.11-0.glibc23
    libc.so.6(GLIBC_2.2.5)(64bit) is needed by MySQL-server-4.1.11-0.glibc23
    libc.so.6(GLIBC_2.3)(64bit) is needed by MySQL-server-4.1.11-0.glibc23
    libcrypt.so.1()(64bit) is needed by MySQL-server-4.1.11-0.glibc23
    libcrypt.so.1(GLIBC_2.2.5)(64bit) is needed by MySQL-server-4.1.11-0.glibc23
    libdl.so.2()(64bit) is needed by MySQL-server-4.1.11-0.glibc23
    libdl.so.2(GLIBC_2.2.5)(64bit) is needed by MySQL-server-4.1.11-0.glibc23
    libm.so.6()(64bit) is needed by MySQL-server-4.1.11-0.glibc23
    libm.so.6(GLIBC_2.2.5)(64bit) is needed by MySQL-server-4.1.11-0.glibc23
    libnsl.so.1()(64bit) is needed by MySQL-server-4.1.11-0.glibc23
    libpthread.so.0()(64bit) is needed by MySQL-server-4.1.11-0.glibc23
    libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by MySQL-server-4.1.11-0.glibc23
    libpthread.so.0(GLIBC_2.3.2)(64bit) is needed by MySQL-server-4.1.11-0.glibc23
    librt.so.1()(64bit) is needed by MySQL-server-4.1.11-0.glibc23
    libz.so.1()(64bit) is needed by MySQL-server-4.1.11-0.glibc23
    perl(DBI) is needed by MySQL-server-4.1.11-0.glibc23
    perl(Data:umper) is needed by MySQL-server-4.1.11-0.glibc23
    perl(File::Basename) is needed by MySQL-server-4.1.11-0.glibc23
    perl(File::Copy) is needed by MySQL-server-4.1.11-0.glibc23
    perl(File::Path) is needed by MySQL-server-4.1.11-0.glibc23
    perl(File::Temp) is needed by MySQL-server-4.1.11-0.glibc23
    perl(Getopt::Long) is needed by MySQL-server-4.1.11-0.glibc23
    perl(POSIX) is needed by MySQL-server-4.1.11-0.glibc23
    perl(Sys::Hostname) is needed by MySQL-server-4.1.11-0.glibc23
    perl(strict) is needed by MySQL-server-4.1.11-0.glibc23
    perl(vars) is needed by MySQL-server-4.1.11-0.glibc23
    sh-utils is needed by MySQL-server-4.1.11-0.glibc23
    After a quick look, many of these directories and files do exist, but it seems like it doesnt know where to look for them? Any help on this one would be much appreciated, been searching the web for hours trying to come up with a solution.

    Thanks!

  2. #2
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    You should not install RPM's direct into Slackware. These packages (even when converted using rpm2tgz) will probably not work. If you want a newer version then the ones Slackware is providing it is better to compile your own. Don't know if that means you have to recompile apache and or php as well, but that could be possible. To ease up things, you could use the buildscripts of Slackware and change them as you want it. You can find those in the source dir of the packages on slackware ftp / mirror or source cd.

    Or download a package on linuxpackages.net if available. The http://www.linuxpackages.net/pkg_details.php?id=6299 seems to be an up to date version for Slackware 10.1

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    6
    Great thanks for fast reply, this is infact exactly what I need. I was able to uncompress it fine. My next question tho is how do I get the new version to start at boot instead of the old. Or better yet, how do I completely remove the old one and get the new one to start at boot? Everytime i check the version it says its still running 4.0.

    Am using College Linux btw.

  4. #4
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    I know collegeLinux is Slackware based but that is about all I know about it. Slackware uses the pkgtools to handle softwarepackages . In your case upgradepkg would remove the old package and install the new one, but I'm not sure what version of Slackware your collegelinux version is based on and what packagemanager it uses. Also I don't know what modifications collegelinux made to their distro compared to Slackware.

  5. #5
    Just Joined!
    Join Date
    May 2005
    Posts
    6
    Getting closer, this look at all familiar?

    mysql: /lib/libc.so.6: version `GLIBC_2.3.4' not found (required by mysql)
    still searching, thanks for the help man.

    Ah, some kind of php error..

  6. #6
    Just Joined!
    Join Date
    May 2005
    Posts
    6
    Well now getting a new error, I think I've hosed it completely. Will have to start again tomorrow.

    These are my requirements:

    # A dedicated (server) machine.
    # Linux or Windows, or any system capable of running all of below.
    # A servlet container, Tomcat (http://jakarta.apache.org/tomcat) 4.1.30+ recommended.
    # (A http server, Apache 2.0+ recommended. NOT REQUIRED however, Tomcat can do the job for you)
    # Database server. MySQL 4.1.3 Beta+ recommended. YOU NEED a server that supports SQL sub-queries (unless you want to modify the source)
    # Java SDK (J2SE/J2EE) 1.4.2_0x+. There's no getting around this one. Might work with 1.5.0 beta, but not tested.
    # ANT for compiling the source (http://ant.apache.org)
    # A text editor (any will do that doesn't messs up newlines or add strange characters (like vim, Emacs, etc) (DON'T USE PICO))
    Is there a linux package out there that comes with some of the newer software that you would recommend? I was doing great until I needed to update the mysql and that threw everything out the window. Where if I could get the new stuff all together I think I'd be fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •