Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Hi, thanks for stopping by, well, lets see, i have just instaled slackware 10.1 on my pc, i have already configured xorg and started X, but i'm having some trouble ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Location
    Mendoza, Argentina, South America :|
    Posts
    13

    Slack 10.1 and Microsoft intellimouse 4.0


    Hi, thanks for stopping by, well, lets see, i have just instaled slackware 10.1 on my pc, i have already configured xorg and started X, but i'm having some trouble with my Microsoft usb mouse, when i move it, the cursor on the screen moves but not like it is suposed to, for example, i move the mouse horizontaly and the cursor moves verticaly, and buttons do not work :S, can anyone help me please ? should i change something in my xorg.conf file ?
    Thanks

  2. #2
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Does this mouse have a trackball. If it does, it should be cleaned.
    At least that is what it looks like to me.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  3. #3
    Just Joined!
    Join Date
    May 2005
    Location
    Mendoza, Argentina, South America :|
    Posts
    13
    no, sorry, i should have explaind a bit more, the mouse is optical, in fact it doesnt have a trackbal, the problem is the mouse inst well configured, based in another post in this formu i changed the "protcol" part in the mosue section of the xorg.conf but i didnt got any results, in fact it worked the same way

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Did you change the protocol to "IMPS/2"?
    Could you post the mouse section of your xorg.conf file.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  6. #5
    Linux Newbie
    Join Date
    Oct 2004
    Location
    Mars
    Posts
    148
    I had some what the same trouble so I finaly got fed up with it and just went out and bought a new mouse. Had trouble in suse 9.1...

  7. #6
    Just Joined!
    Join Date
    May 2005
    Location
    Mendoza, Argentina, South America :|
    Posts
    13
    yes, i did change it to "imps/2" but i didnt notice any change

  8. #7
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    I had this very same problem with my Logitech optical mouse. I fixed it by creating a new symlink in /dev...

    Code:
    rm /dev/mouse
    Code:
    ln -s /dev/input/mice /dev/mouse
    Then, configured /etc/X11/xorg.config thusly...

    Code:
    # **********************************************************************
    # Core Pointer's InputDevice section
    # **********************************************************************
    
    Section "InputDevice"
    
    # Identifier and driver
    
        Identifier "Mouse1"
        Driver "mouse"
        Option "Buttons" "5"
        Option "ZAxisMapping" "4 5"
        Option "Protocol" "IMPS/2"
        Option "Device" "/dev/mouse"
    It fixed mine. I hope it helps....
    Linux Mint + IceWM Registered: #371367 New Members: click here

  9. #8
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Quote Originally Posted by turok
    yes, i did change it to "imps/2" but i didnt notice any change
    You changed it to "IMPS/2" or "imps/2"?
    They are not the same.
    Does your Input device section look like Dapper Dan's?
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  10. #9
    Just Joined!
    Join Date
    May 2005
    Location
    Mendoza, Argentina, South America :|
    Posts
    13
    well, i did exactly what Dapper Dan said, so mi xorg.conf is exactly like that, but i had no changes, i also have a ps2 mouse, so it would be grate if anyone could help me to configure it as a secondary mouse, but if i could make mi usb mouse work it would be better. Any suggestions to try ? Thanks a lot

  11. #10
    Just Joined!
    Join Date
    May 2005
    Location
    Mendoza, Argentina, South America :|
    Posts
    13
    i solved it !
    well, what i had to do is to uncomment the following lines in /etc/rc.d/rc.modules

    /sbin/modprobe usb-uhci
    /sbin/modprobe hid
    /sbin/modprobe usbmouse
    /sbin/modprobe mousedev
    /sbin/modprobe evdev


    and change the device field in the xorg.xonf to :

    Option "Device" "/dev/input/mice"

    thanks a lot !

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •