Find the answer to your Linux question:
Results 1 to 3 of 3
First, forgive the lack of specific details I am able to give. I don't have my box handy here at work. I use Slackware 10.1. I just upgraded to the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    3

    Kernel Upgrade = console framebuffer doesn't work


    First, forgive the lack of specific details I am able to give. I don't have my box handy here at work.

    I use Slackware 10.1. I just upgraded to the newest 2.6 kernel the other day. I previously had lilo configured to pass something like vga=771 to the kernel at boot. It gave me a nice 1024x768x256 resolution for textmode. I liked it. Ever since I upgraded my kernel, this no longer works. The screen just goes black after LILO does its thing. But, if I have my default runlevel set to 4, KDE eventually boots up. Also, if I set vga=normal, I can get a normal, boring textmode just fine.

    I based my new kernel configuration off my previous one, but I am told that's not 100% foolproof. Did I miss something? Should I have enabled an option that I didn't or vice versa? I muck around in the console a lot and I'd like to get my custom framebuffer back.

  2. #2
    Just Joined!
    Join Date
    May 2005
    Posts
    11
    had the same problem its pretty simple (but ya just have to come up with it :P)
    go configure the kernel with make menuconfig (or any other you prefer) and go to the section device drivers. from there go to graphics support and enable frame buffer support then a lot more option will be enabled locate your vidieocard and enable the support for it(if your video card isnt in the list try vesa vga graphics support go down and go to console display driver support, once there select Framebuffer console support. exit to graphics devices and go to logo configuration, select bootup logo and then the logos you prefer (i selected 16-color and 224-color logo but you choose yourself) then you are done recompile and if your having trouble compiling it (what i doubt caus you already did :P) you can see a nice little guide here http://www.linuxquestions.org/questi...hreadid=127095

    ps : lilo can now be configured the way you did it before with kernel 2.4

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    3
    Thanks, got it working.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •