Find the answer to your Linux question:
Results 1 to 4 of 4
I've tried and tried, searched and searched, and cannot find out how to get FTP working. It almost seems as if I'm the only one on earth with this problem, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    1

    FTP Woes


    I've tried and tried, searched and searched, and cannot find out how to get FTP working. It almost seems as if I'm the only one on earth with this problem, and it has become quite frustrating.

    Until February, I had been using old Slackware 9. I had everything working, Apache, MySQL, FTP, PHP... You name it. It wasn't until I upgraded to Slackware 10 (And 10.1) that I can't get the FTP to work. I had given up until recently, when I decided I REALLY wanted FTP again.

    The program is running of course, as I can log in as anonymous. However, if I try to log in as just a plain user, let's say I named it "people", I get:

    220 *FTP SERVER TYPE JUNK HERE*
    USER people
    331 Please specify the password.
    PASS xxxx
    530 Login incorrect.

    I've tried this with both ProFTPd and vsFTPd, and get the same 530 error. Both the username and password are DEFINATELY correct. I've gone through both configuration files (vsftpd.conf and proftpd.conf), played with ftpusers, inetd.conf... Nothing works (These are the only file configurations I see brought up in online forums). I'm no expert on Linux in any way... I'm just a casual user who wants Linux simply for better security for the everyday things I do, so my knowledge on what to do is very limited...

    Does anyone know what's wrong, or have any suggestions on what I can do to fix this? I'm willing to try anything, so if anyone has any thoughts on this, please respond. If you need any additional information, please ask and I'll post it right away.

    EDIT:

    Problem solved. It was the way the users were being created, heh.

  2. #2
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    haha good Job Muras
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  3. #3
    Just Joined!
    Join Date
    Feb 2006
    Posts
    2
    Quote Originally Posted by Muras
    Problem solved. It was the way the users were being created, heh.
    I too am having this problem, and I too have had no luck with searching... does anybody know what the issue could be with the user creation? This post explains my problem exactly, but unfortunately, he didn't list the fix...

    Thanks,
    Tom

  4. #4
    Just Joined!
    Join Date
    Feb 2006
    Posts
    2
    further research yeilds that I believe that he was talking about the user's shells being created correctly. as I am creating ftp users which have a null shell (they don't log in on a terminal), i added
    Code:
    check_shell=NO
    to my vsftpd.conf, and now all is well

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •