Find the answer to your Linux question:
Results 1 to 5 of 5
What am I missing here? I have slackware 10.1 installed as my host system, works fine, can properly mount and use the cdrom without issue. I have slackware 10.1 installed ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Posts
    5

    Can't mount cdrom in slackware 10.1 UML


    What am I missing here? I have slackware 10.1 installed as my host system, works fine, can properly mount and use the cdrom without issue. I have slackware 10.1 installed as a uml, works mostly fine, but I canoot get it to even show the ubd device associated with the cdrom in /dev nevermind mount it.

    I've made sure to unmount the cdrom in the host before launching the uml guest. I've tried launching the uml as root to ensure that it wasn't a permissions issue. I'm launching the uml with this
    Code:
    ./linux ubd0=root_fs.cow,root_fs ubd1=swap_fs.cow,/var/uml/swap_fs ubd2=/dev/cdrom devfs=nomount con=pty con0=fd:0,fd:1 mem=64M eth0=tuntap,uml-slackware-server
    I've also tried using ubd2r=/dev/cdrom to mount it read only, and ubd2=/dev/hdd to skip the link and use the device name directly.


    The only thing in the boot messages that even relates to ubd2 is this
    Code:
    Initializing software serial port version 1
     ubda: unknown partition table
     ubdb: unknown partition table
     ubdc: unknown partition table
    But it issues that message for a and b aswell, which I assume map to /dev/ubd0 and /dev/ubd1, aka the root partition and swap.

    In the uml guest, /dev/ubd0 and /dev/ubd1 exist, but not /dev/ubd2.
    I'm using a 2.6.11.11 kernel that I compiled myself, but it has the exact same options selected as the host's kernel, except the ARCH=um of course, and as I said, the cdrom works perfectly in the host. I also tried recompiling the kenel (in a fresh source directory) just now as I typed this message, and still nothing.
    What am I doing wrong here?
    I'm pretty green to linux so this was a major undertaking, but up until now I have had no trouble getting everything to work.

  2. #2
    Just Joined!
    Join Date
    Jun 2005
    Posts
    5
    What the? I just checked, and I can't even get it to mount additional disk images.
    I created a new disk image containing all the package folders copied of the slackware cdrom, and while it works perfectly on the host using loop, it refuses to show in /dev/ubd*
    I'm thoroughly confused now. Any help would be greatly appreciated.

  3. #3
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    When you installed 10.1 did you have these issues running the 2.4 kernel? I'm thinking you're having a udev situation here which is supported in Slackware with the 2.6* kernels.

    http://www.kernel.org/pub/linux/util...plug/udev.html
    Linux Mint + IceWM Registered: #371367 New Members: click here

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jun 2005
    Posts
    5
    Seems you're correct. Since I've run the 2.6 kernel on the uml guest since it's inception I never knew that was the cause. I rolled back to a hastily downloaded prebuilt uml 2.4.27 kernel and it works perfectly. I suppose I have a lot of research into the 2.6's and udev before I go that route.

    Thanks for the tip

  6. #5
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    I didn't like udev at first, I guess simply because it is new, however, I've grown to appreciate it. It makes very good sense to have it if you are running, say, a usbstick and an external usbdrive. udev keeps them seperate and always assigned to the same location in /dev.
    Linux Mint + IceWM Registered: #371367 New Members: click here

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •