Find the answer to your Linux question:
Results 1 to 7 of 7
The install finished fine. Had to re-install to replace my grub MBR that was left over from SuSe. Booting goes well until after freeing unused kernel memory. Then I get ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Location
    Calhoun, GA USA
    Posts
    42

    kernel panic with 10.1 install on laptop


    The install finished fine.
    Had to re-install to replace my grub MBR that was left over from SuSe.

    Booting goes well until after freeing unused kernel memory. Then I get the following:

    Code:
    Warning: unable to open an initial console.
    Kernel panic: No init found.  Try passing init= option to kernel.
    What do I do to get past this?

  2. #2
    Just Joined!
    Join Date
    Feb 2005
    Location
    Calhoun, GA USA
    Posts
    42
    Bump.

    A whopping five people have viewed other than me.
    No takers yet though.

    I'm gonna' run the install one more time and see where that gets me.

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Location
    Calhoun, GA USA
    Posts
    42
    I've run the installer several more times. I still get the same kernel panic.

    Still no takers?

  4. #4
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    hmm, looks like it can't start a runlevel (hypothesis?). Do you have a /etc/inittab fle? And if so, what is you runlevel set to?
    Operating System: GNU Emacs

  5. #5
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    (I think the forum rules suggest at least 24 hours before bumping a post. You may come to notice that traffic is lighter at some times than others. Next time you have a real emergency, try to have it between around 8:am-2m weekdays.)

    What's in your grub.conf or lilo.conf boot script? The kernel, which appears to load okay, is in the /boot directory. The kernel expects to find the file /sbin/init. If you have a separate /boot partition, then you need to pass a parameter to the kernel something like 'root=/dev/hda3' so /sbin/init can be found (I'd put it in even without a separate partition). If you use an initrd, if it is not entered correctly in the boot script (that is: if it's location is not correctly entered) then you will get a kernel panic. If you need more help, you should explain how your drives and partitions are setup (along with your bootloader configuration).
    /IMHO
    //got nothin'
    ///this use to look better

  6. #6
    Just Joined!
    Join Date
    Feb 2005
    Location
    Calhoun, GA USA
    Posts
    42
    I re-went through the installation and used the expert lilo setup. So at least it boots like a charm now. Still having some issues though.

    normal user mounting of drives and network.

    How much I'd love slackware if only the network connection were more dependable.

  7. #7
    Just Joined!
    Join Date
    Apr 2005
    Location
    kobe,japan
    Posts
    27
    normal user mounting of drives is easy enough. just add a "user" option in the fstab line of the drive or device you want to mount. as for network issues, ive never really had any big ones with slackware. if your on a lan, just boot with the cable connected and it should all work fine. if not, please post your dmesg output.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •