Find the answer to your Linux question:
Results 1 to 7 of 7
After setup of 10.1and following jetblackz's installing and configuring guide for SL10.,I can play music as root. As user in KDE there is sound but get "breaking glass" sound and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Posts
    72

    cd audio as user


    After setup of 10.1and following jetblackz's installing and configuring guide for SL10.,I can play music as root. As user in KDE there is sound but get "breaking glass" sound and kscd gives 'no disk' error or 'permission' error--no music. Slackware Handbook not helpful here. Not sure how to give myself permission to play cds as user. I did edit fstab's noauto,owner,ro sexn to noauto,users,ro for both cdrom and cdrom1. Did mkdir /dev/cdrom1. And added ' user' to /etc/group audio,games,cdrom.disk,wheel groups as per SL Handbook lead. Even tried fstab with user instead of users. But after reboots get no music as user. Is there an easier way to get cd music as user. And at one pt lost music as root as well. Forget about trying to record for now..

  2. #2
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Buenos Aires, Argentina
    Posts
    908
    Just so you know, you don't mount audio-cds
    serzsite.com.ar
    "All the drugs in this world won\'t save you from yourself"

  3. #3
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Have you added yourself to the audio group? If not do so with
    Code:
    su 
    [rootpass]
    usermod -g audio username
    (replace username with your username)

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jun 2006
    Posts
    3

    Don't get music from audio CD as user

    Hi there,
    i get nearly the same problem, only that i am usin fluxbox
    and xmms denies the access to the audio cd as user
    but access as root is granted....

    what do i have to do to get access as user ??

  6. #5
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    Add yourself to the cdrom/audio/video/disk groups

    the answer is above your post ! )

  7. #6
    Just Joined!
    Join Date
    Jun 2006
    Posts
    3

    cd audio access ide xmms slackware mount

    do "ls -l /dev/cdrom"
    there is sometihng like an systemsoftware link pointin to -----> xxxxx
    then change your cdrom to group xxxxx by typin
    "chgrp cdrom /dev/xxxxx" e.g hdb or hdc

    then add youself to "cdrom" and "audio" group by typin
    "usermod -G cdrom,audio USERNAME"

    replace USERNAME by your userlogin in linux

    don't forget to do it as su (superuser=root)
    by typin
    "su"
    "rootpassword"

    thx for your help

    as for what i read is necesary to change the ide cdrom drive trough chgrp to cdrom, because inthe system the ide cdrom belongs original to the disk group

    and if you add the user to the disk group, he has access to delete the entire harddrive

    cya

  8. #7
    Just Joined!
    Join Date
    Jun 2006
    Posts
    12

    Another way to make slack more user friendly

    Quote Originally Posted by lestoil
    And at one pt lost music as root as well. Forget about trying to record for now..
    Here is how I do it;
    First I change the default setup in /etc/fstab here is my fstab:
    Code:
    /dev/hdb2        swap             swap        defaults         0   0
    /dev/hdb3        /                reiserfs    defaults         1   1
    /dev/hda1        /assholeNT       ntfs        ro               1   0
    /dev/hdb1        /kubuntu         ext3        ro               1   0
    /dev/cdrom       /mnt/cdrom       auto        noauto,users,ro  0   0
    /dev/fd0         /mnt/floppy      auto        noauto,users     0   0
    devpts           /dev/pts         devpts      gid=5,mode=620   0   0
    proc             /proc            proc        defaults         0   0
    That way I can right click on the desktop and create a kde link to open my cdrom without having to mess with group permissions. As you can see I triple boot and am able to copy stuff from other os installs. It is a good idea to use the noauto option for cdrom and floppy as the automount function can cause havoc in KDE!
    Even so if you have kscd running when you put in a data cd you have to exit kscd to eject the cd properly...it is one of the KDE shortcomings that automount is haywire. Remember that you have to wait 5 seconds after unmounting a volume before you eject the media..this applies to both the cdrom and the floppy...the program mount has a mandatory delay that alows the filesystem write to complete. In NTFS based windows OSes the lack of a file system write time buffer sometimes causes system hangs...so this situation is not just a linux quirk. At least in kde you can get around the hang without having to off processes!

    I can understand why Patrick chose to have the safest setting at install but if you are the only user and know why it can be unsafe to alow cd access on a networked computer then it makes sense to not alow it by default. I also make a copy of the shutdown bin from /sbin, and place it in bin then do a chmod u+x /bin/shutdown ....this way I can create a little script that I call byebye.sh
    Code:
    #!/bin/sh
    
    shutdown -h now
    and another called rebooter.sh
    Code:
    #!/bin/sh
    
    shutdown -r now
    if you right click on the scripts you can make them executable through the properties menu....I then save them in a folder in my /home that I call scripts.
    After doing that I add them as program items to the system menu in the kde programs menu...add fancy icons and make sure the path is set. That way I have a shutdown and reboot in my user profile ...I also do this for my wife and daughters profiles.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •