Find the answer to your Linux question:
Results 1 to 10 of 10
Hi guys, managed to compile i2c support into my kernel, simply great, but now I have to load the modules manually everytime I boot... The concerned modules are listed in ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429

    i2c & lm_sensors on minislack 1.1


    Hi guys, managed to compile i2c support into my kernel, simply great, but now I have to load the modules manually everytime I boot... The concerned modules are listed in /etc/rc.d/rc.modules, it is executable, and a second time in an autostart file (bash script in the ~/Desktop/Autostart folder for Xfce). Yet it still refuses to work. I even went as far as giving root rights to myself for the /sbin/modprobe command, to no avail.

    Everytime I boot up and execute 'sensors', it says 'no sensors found', and I have to modprobe all the modules manually (only three but hey...) Now I've noticed my /etc/modules.conf file is completely empty, is this normal? Done some reading, but the content of sample files look far to complicated for me, and I'm afraid I'm gonna screw up something if I use one of them instead of my default one.

    Can anyone help me out?
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

  2. #2
    Just Joined!
    Join Date
    Nov 2004
    Location
    WGS84 phi = 45 48 31.7 lambda = 15 57 49.0
    Posts
    65
    first try executing as root
    Code:
    # sensors-detect
    it should detect onboard sensors, if they are compiled as kernel modules, and give you lines which u must add to /etc/modules.conf & /etc/modprobe.conf

    hope it helps

  3. #3
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429
    Hi, thanks for your help, but I already did that - I know which sensors are to be probed. I added the lines to one of the startup scripts at /etc/rc.d/, but to no avail...

    The fact I can modprobe the sensors manually shows they have been detected, it just won't load automatically
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

  4. #4
    Just Joined!
    Join Date
    Nov 2004
    Location
    WGS84 phi = 45 48 31.7 lambda = 15 57 49.0
    Posts
    65
    did u add
    Code:
    /usr/bin/sensors -s
    to /etc/rc.d/rc.local?

    that should load the sensors!

  5. #5
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429
    It is in the rc.modules file in the/etc/rc.d/ folder... Anyway, I suppose the -s option means 'silent', am I right? It is there, but since the modprobes are not executed rightly, the 'sensors' command doesn't seem the problem to me...

    Anyway, maybe this also plays a role:at the end of the configuration, lm_sensors tells me it has an lm_sensors.init file which I should place in /etc/rc.d/init.d/ to make it start at boot. That should be available in /usr/share/doc/packages/sensors/prog/init/lm_sensors.init, but I can't find it there. I created the path, tried to run the configuration again in the hope it would be created this time, to no avail.

    Also, I haven't got a /etc/rc.d/init.d/ directory neither... Don't know if this is Slackware-related though. SuSE seemed to have it AFAIK.
    If I execute modprobe & sensors manually, i get some results - temps, present memory (DIMMs), fan speeds, ... So it does work...
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

  6. #6
    Just Joined!
    Join Date
    Nov 2004
    Location
    WGS84 phi = 45 48 31.7 lambda = 15 57 49.0
    Posts
    65
    ok, then i suggest to put lines, given by sensors-detect in your /etc/rc.d/rc.local and not /etc/rc.d/rc.modules

    i did and is working just fine, anyway here is my configuration

    /etc/modprobe.conf
    alias char-major-89 i2c-dev

    /etc/rc.d/rc.local
    # I2C adapter drivers
    modprobe i2c-nforce2
    modprobe i2c-isa
    # I2C chip drivers
    modprobe w83627hf
    # sleep 2
    /usr/local/bin/sensors -s # recommended


    and about that .../init.d/ stuff i think that u don't need it for minislack or any other slack flavored distro

  7. #7
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429
    Ok, thanks, can I know which motherboard you have? I've got an nForce2 too, an A7N8X-E. Anyway, all of those lines look familar to me, I'll try putting the lines as you said. Thanks a lot. I'll see what it gives and let you know .

    Thanks for your help so far
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

  8. #8
    Just Joined!
    Join Date
    Nov 2004
    Location
    WGS84 phi = 45 48 31.7 lambda = 15 57 49.0
    Posts
    65
    well it is an Nforce3 MSi K8n Neo2 Platinum, and i should remove that nforce2 line, maybe i will

  9. #9
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429
    Hi there, I did as you said, I moved the commands from my rc.i2c to rc.local, and added the line to /etc/modprobe.conf, and it works like a charm now . Now all I have to do is get rid of that segmentation fault in torsmo, and I can finally monitor my system .
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

  10. #10
    Just Joined!
    Join Date
    Nov 2004
    Location
    WGS84 phi = 45 48 31.7 lambda = 15 57 49.0
    Posts
    65
    im just happy i helped

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •