Find the answer to your Linux question:
Results 1 to 4 of 4
I've tried to locate an answer but keep coming up empty. I have a HP printer locally connected to a FC3 box. It is configured and runs perfectly. On the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630

    the IPP request failed for an unknown reason...


    I've tried to locate an answer but keep coming up empty. I have a HP printer locally connected to a FC3 box. It is configured and runs perfectly. On the FC box, the cups daemon is running and nmap says port 631 is open.

    When I connect to this printer from my Slackware 10.1 box on the same LAN, using http://localhost:631 in Firefox, it finds the remote printer on the cups network at the FC box and I'm able to print a test page from the Slackware box. Port 631 is open on the Slackware box, and guarddog is not blocking the port. Since I can print a test page from the cups configurator, everything should work right?

    I can't print any documents from Slackware. I tried configuring with kprinter, and when it tries to connect to the cups network, I get...

    An error occured while retrieving the printer list:
    Connection to CUPS server failed. Check that the CUPS server is correctly installed an running. Error: the IPP request failed for an unknown reason.
    I've tried everything I can think of but nothing seems to correct this. What am I doing wrong? Any help appreciated. Thanks...
    Linux Mint + IceWM Registered: #371367 New Members: click here

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Everything is working now. Since the printer was originally installed as a local printer to the Slackware box, I think it was confused. Even though I pointed it to the FC box and port 631, it was looking for it at that address but on the Slackware box.

    I created and configured a new printer throught the cups utility and everything works. Thanks for reading.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    6
    I have the same problem and can't seem to be able to figure out what's wrong. I am using Mandriva 2007.

    Here's my cupsd.conf file:

    Classification none

    DefaultCharset UTF-8
    DefaultLanguage en
    Printcap /etc/printcap


    PrintcapFormat BSD

    RemoteRoot remroot

    SystemGroup lpadmin root
    ServerCertificate /etc/cups/ssl/server.crt

    ServerKey /etc/cups/ssl/server.key
    <Location />
    Encryption IfRequested
    Satisfy All
    Order allow,deny
    Allow @LOCAL
    Allow localhost
    </Location>
    <Location /admin>
    Encryption Required
    Satisfy All
    Order allow,deny
    Allow @LOCAL
    Allow localhost
    </Location>
    <Location /admin/conf>
    AuthType Basic
    Require user @SYSTEM
    Encryption IfRequested
    Satisfy All
    Order allow,deny
    Allow @LOCAL
    Allow localhost
    </Location>

    HostnameLookups Off

    KeepAlive On
    KeepAliveTimeout 60

    MaxClients 100
    MaxRequestSize 0m


    Timeout 300
    Listen *:631
    Listen /var/run/cups/cups.sock

    AccessLog /var/log/cups/access_log

    ErrorLog /var/log/cups/error_log

    PageLog /var/log/cups/page_log

    MaxLogSize 1m

    LogLevel debug2


    PreserveJobHistory On

    PreserveJobFiles Off
    AutoPurgeJobs No


    MaxJobs 0
    MaxJobsPerPrinter 0

    MaxJobsPerUser 0

    User lp

    Group sys

    RIPCache 8m


    FilterLimit 0


    DataDir /usr/share/cups
    DocumentRoot /usr/share/cups/doc

    RequestRoot /var/spool/cups

    ServerBin /usr/lib/cups


    ServerRoot /etc/cups

    TempDir /var/spool/cups/tmp


    Browsing On
    BrowseProtocols CUPS


    BrowsePort 631


    BrowseInterval 30

    BrowseTimeout 300

    BrowseAddress @LOCAL
    BrowseAllow @LOCAL


    BrowseOrder allow,deny

    ImplicitClasses On


    ImplicitAnyClasses On

    HideImplicitMembers Yes

    BrowseShortNames Yes

    # Unknown
    defaultauthtype Basic
    <policy default>
    <limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job>
    require user @OWNER @SYSTEM
    order deny,allow
    </limit>
    <limit Pause-Printer Resume-Printer Set-Printer-Attributes Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After CUPS-Add-Printer CUPS-Delete-Printer CUPS-Add-Class CUPS-Delete-Class CUPS-Accept-Jobs CUPS-Reject-Jobs CUPS-Set-Default>
    authtype Basic
    require user @SYSTEM
    order deny,allow
    </limit>
    <limit Cancel-Job CUPS-Authenticate-Job>
    require user @OWNER @SYSTEM
    order deny,allow
    </limit>
    <limit All>
    order deny,allow
    </limit>
    </policy>

    Here's my error log file:
    http://www.arnit.net/error_log.txt


    Somebody please help me!

    Thanks

    Ali

  4. #4
    Just Joined!
    Join Date
    Jan 2005
    Posts
    6
    I finally managed to get it working. Here's what I did:

    I reinstalled CUPS using URPMI. I still got the error message. I added a local printer and then there was no error message but the problem was, I couldn't print using that printer. So, I removed it and I started getting the same error message!!!

    So this time, I added a remote SMB printer, shared on Windows Machine. I couldn't open the local network browser, so I added the location and printer name manually and it worked!

    Thanks

    Ali

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •