Find the answer to your Linux question:
Results 1 to 8 of 8
Got my pc upstairs which i want to install Linux Slackware on. But fdisk keeps telling me my HDD is write protected. i totally wiped it and it is currently ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    7

    Help - fdisk and partition creating.


    Got my pc upstairs which i want to install Linux Slackware on.

    But fdisk keeps telling me my HDD is write protected.

    i totally wiped it and it is currently partitionless.

    can any1 pretty much tell me exactly wot to type from when i enter a disk to pretty much just install SlackWare.

    HDD is located at /dev/hda.

    Thank You in advance

    LeeCuz

    Also can someone add me to msn? lee_cousens@hotmail.com

  2. #2
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    This is new, a write protected hard drive.

    I know in the BIOS you can change the write protections of a floppy, but I have never heard of a hard drive being write protected.

    You could check the BIOS though.
    Upon bootup, look for the message, "press **** to Enter Setup" or something similar.
    Most BIOS are accessed by hitting F1, F2, Del at boot time.
    Just poke around in there. The keys to move around will be shown somewhere on the screen.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  3. #3
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    You could try hdparm:
    Code:
    /sbin/hdparm /dev/sdb
     
    /dev/sdb:
     readonly     =  0 (off)
     geometry     = 2213/255/63, sectors = 35566480, start = 0
    If it is set for read only, do 'hdparm -r 0 /dev/hda'
    /IMHO
    //got nothin'
    ///this use to look better

  4. #4
    Just Joined!
    Join Date
    Jul 2005
    Posts
    7
    Just tried that

    On changing the setting from read only. i go into FDisk and try partition my drive.

    Still wont write to the Harddrive. and when i reboot. its automatically reset to Read Only.

    Any Insight?

    LeeCuz,

  5. #5
    Just Joined!
    Join Date
    Jul 2005
    Posts
    7
    Fixed.

    Turns out that /dev/hda was my CDROm drive and i was trying to partition it lmao.

    My bad.

    my HardDrive is /dev/hdc which therefore partitioned perfectly.

    Thank You for all your help guys.

    Kind Regards,
    Leecuz... Im sure ill be back when SlackWare has installed for more help.

  6. #6
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817

    Re: Help - fdisk and partition creating.

    Quote Originally Posted by LeeCuz
    HDD is located at /dev/hda.
    Gosh, and I was sure that was the hard drive

    I kind of make a habit of doing 'fdisk -l' before doing things to my drives, just to be sure. I'm glad you found the problem sooner rather than later.
    /IMHO
    //got nothin'
    ///this use to look better

  7. #7
    Qis
    Qis is offline
    Just Joined!
    Join Date
    Nov 2006
    Posts
    1

    just a me-too!

    Same error, same cause... the clue should've been in the size of the disk... 688 megs.. but i thought it was a 40gig hdd.

    :cretin:

    -Qis

  8. #8
    Linux Newbie TrashOverride's Avatar
    Join Date
    May 2004
    Location
    @home...soon in your homes ;) /usr/src/bulgaria
    Posts
    162
    why dont u try cfdisk /dev/hdc its more user friendly that fdisk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •