Find the answer to your Linux question:
Page 2 of 4 FirstFirst 1 2 3 4 LastLast
Results 11 to 20 of 40
Well Failure again....... i tried all 4 raid settings in my bios. the error i get is ide0: i/o resource 0xf0-gxf7 not free hdc: recognize's my cdrom so everytime it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jul 2005
    Posts
    15

    7 is near


    Well Failure again....... i tried all 4 raid settings in my bios. the error i get is ide0: i/o resource 0xf0-gxf7 not free
    hdc: recognize's my cdrom
    so everytime it recognizes my cd rom and just for the hell of it I disabled it and only had my sata hd enabled still no luck.

  2. #12
    Linux Newbie
    Join Date
    Apr 2005
    Location
    CT --> PA
    Posts
    170
    i'm thinking the same thing toward puntmuts line of thinking...i don't think your fstab is loading things correctly.

    post your fstab file...lets see what's getting mounted (or trying to mount) where
    Chicks dig giant mechanized war machines

  3. #13
    Just Joined!
    Join Date
    Jul 2005
    Posts
    15

    stock

    heres my 2.4 kernal i havent a clue how to get the fstab for the 2.6

    /dev/hda2 swap swap defaults 0 0
    /dev/hda1 / reiserfs defaults 1 1
    /dev/hda3 /winblows ntfs ro 1 0
    /dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
    /dev/fd0 /mnt/floppy auto noauto,owner 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    proc /proc proc defaults 0 0

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Newbie
    Join Date
    Apr 2005
    Location
    CT --> PA
    Posts
    170
    ok, hold on. your bootpart is running reiserFS?
    Chicks dig giant mechanized war machines

  6. #15
    Just Joined!
    Join Date
    Jul 2005
    Posts
    15

    ya

    ya it is and i enabled that in the kernal config.

  7. #16
    Linux Newbie
    Join Date
    Apr 2005
    Location
    CT --> PA
    Posts
    170
    (never having used SATA, yet....) i believeslack mounts SATA drives in the /dev/sda mount area, so i believe you are trying to mount the wrong fs on the wrong mount point....i would say if your reiserFS is your root mount point, and it's on a /dev/sda1 - your problem might be the fact that you're telling it that it is @ /dev/hda1
    Chicks dig giant mechanized war machines

  8. #17
    Just Joined!
    Join Date
    Jul 2005
    Posts
    15

    hmm

    So I changed it in lilo would i also have to tweak my kernal compile again? I made lilo boot dev/sda1 no joy..

  9. #18
    Just Joined!
    Join Date
    Jul 2005
    Posts
    15

    another that didnt work

    heres another attempt that worked for my friend but not me check it out and make sense of this.

    > This document describes how to create and install an initrd, which may be
    > required to use the 2.6 kernel. Also see "man mkinitrd".
    >
    > 1. What is an initrd?
    > 2. Why to I need an initrd?
    > 3. How do I build the initrd?
    > 4. Now that I've built an initrd, how do I use it?
    >
    >
    > 1. What is an initrd?
    >
    > Initrd stands for "initial ramdisk". An initial ramdisk is a very small
    > Linux filesystem that is loaded into RAM and mounted as the kernel boots,
    > and before the main root filesystem is mounted.
    >
    > 2. Why do I need an initrd?
    >
    > The usual reason to use an initrd is because you need to load kernel
    > modules before mounting the root partition. Usually these modules are
    > required to support the filesystem used by the root partition (ext3,
    > reiserfs, xfs), or perhaps the controller that the hard drive is attached
    > to (SCSI, RAID, etc). Essentially, there are so many different options
    > available in modern Linux kernels that it isn't practical to try to ship
    > many different kernels to try to cover everyone's needs. It's a lot more
    > flexible to ship a generic kernel and a set of kernel modules for it. The
    >
    > generic 2.6 kernel in Slackware supports the ext2 filesystem (which is
    > used by the initrd), and also supports most IDE controllers (much like the
    >
    > old bare.i kernel). So, if you have an IDE based system that uses the
    > ext2 filesystem, then you will not need to use an initrd to boot.
    > Otherwise, read on.
    >
    > 3. How do I build the initrd?
    >
    > The easiest way to make the initrd is to use the mkinitrd script included
    > in Slackware's mkinitrd package. We'll walk through the process of
    > upgrading to the 2.6.7 Linux kernel using the packages found in
    > Slackware's testing/packages/linux-2.6.7/ directory.
    >
    > First, make sure the kernel, kernel modules, and mkinitrd package are
    > installed (the current version numbers might be a little different, so
    > this is just an example):
    >
    > installpkg kernel-generic-2.6.7-i486-3.tgz
    > installpkg kernel-modules-2.6.7-i486-2.tgz
    > installpkg mkinitrd-1.0.1-i486-1.tgz
    >
    > Change into the /boot directory:
    >
    > cd /boot
    >
    > Now you'll want to run "mkinitrd". I'm using reiserfs for my root
    > filesystem, and since it's an IDE system the reiserfs module will be
    > the only one I need to load:
    >
    > mkinitrd -c -k 2.6.7 -m reiserfs
    >
    > This should do two things. First, it will create a directory
    > /boot/initrd-tree containing the initrd's filesystem. Then it will
    > create an initrd (/boot/initrd.gz) from this tree. If you wanted to,
    > you could make some additional changes in /boot/initrd-tree/ and
    > then run mkinitrd again without options to rebuild the image. That's
    > optional, though, and only advanced users will need to think about that.
    >
    > Here's another example: Build an initrd image using Linux 2.6.7 kernel
    > modules for a system with an ext3 root partition on /dev/hdb3. Note
    > that you need both the jbd and ext3 modules to use ext3:
    >
    > mkinitrd -c -k 2.6.7 -m jbd:ext3 -f ext3 -r /dev/hdb3
    >
    >
    > 4. Now that I've built an initrd, how do I use it?
    >
    > Now that you've got an initrd (/boot/initrd.gz), you'll want to load
    > it along with the kernel at boot time. If you use LILO for your boot
    > loader you'll need to edit /etc/lilo.conf and add a line to load the
    > initrd. Here's an example section of lilo.conf showing how this is
    > done:
    >
    > # Linux bootable partition config begins
    > image = /boot/vmlinuz-generic-2.6.7
    > initrd = /boot/initrd.gz
    > root = /dev/hda6
    > label = Linux267
    > read-only
    > # Linux bootable partition config ends
    >
    > The initrd is loaded by the "initrd = /boot/initrd.gz" line.
    > Just add the line right below the line for the kernel image you use.
    > Save the file, and then run LILO again ('lilo' at the command line).
    > You'll need to run lilo every time you edit lilo.conf or rebuild the
    > initrd.
    >
    > Other bootloaders such as syslinux also support the use of an initrd.
    > See the documentation for those programs for details on using an
    > initrd with them.
    >

  10. #19
    Just Joined!
    Join Date
    May 2006
    Posts
    5
    Quote Originally Posted by jnorcal
    My Kernal seems to not recognize my sata hd's when it gets to vfs it crash's. Im as fresh as they come to linux but i followed this site's direction in makeing it. http://www.linuxquestions.org/questions/answers/408


    heres my lilo file
    # LILO configuration file
    # generated by 'liloconfig'
    #
    # Start LILO global section
    boot = /dev/hda
    message = /boot/boot_message.txt
    prompt
    timeout = 1200
    # Override dangerous defaults that rewrite the partition table:
    change-rules
    reset
    # VESA framebuffer console @ 1024x768x256
    vga = 773
    # Normal VGA console
    # vga = normal
    # VESA framebuffer console @ 1024x768x64k
    # vga=791
    # VESA framebuffer console @ 1024x768x32k
    # vga=790
    # VESA framebuffer console @ 1024x768x256
    # vga=773
    # VESA framebuffer console @ 800x600x64k
    # vga=788
    # VESA framebuffer console @ 800x600x32k
    # vga=787
    # VESA framebuffer console @ 800x600x256
    # vga=771
    # VESA framebuffer console @ 640x480x64k
    # vga=785
    # VESA framebuffer console @ 640x480x32k
    # vga=784
    # VESA framebuffer console @ 640x480x256
    # vga=769
    # End LILO global section
    # Slack NEW begins
    image = /boot/vmlinuz-2.6.10
    root = /dev/hda1
    label = Slack_2.6.10
    read-only
    # Slack NEW ends
    # Slack OLD begins
    image = /boot/vmlinuz-old
    root = /dev/hda1
    label = Slack_OLD
    read-only
    # Slack OLD ends
    Hi, same problem here. Here's what I've found (also EXACT error as you).
    if I copy the sata.i/* to the /boot directory they work, however when I copy the test.s files /boot and configure lilo, I get the same error. I've recompiled my 2.6 kernels, even the 2.6.16.15 and .16 versiosn with the same problem.

    I've tried mkinstr for the ext3 (from the README. in /boot) and again with the ext2 file type. I've tried everything except for checking the scsi sata drivers, which I'll do next, but that failed for you already. It always says add "root=" message. I've used the slackware cd and at the boot prompt typed
    mount root=/dev/hda1 and everything would run, but not with my 2.6 kernel.

    ALSO, hda1 is the IDE (uses New Enhanced IDE driver beta) for SATA drives. It looks like sda is no longer used, and maybe we need this new beta driver that loads with sata.i?

    Thanks
    John

  11. #20
    Just Joined!
    Join Date
    May 2006
    Posts
    5
    Hello, this is a VERY COMMON problem with the 2.6.xx kernels. I've searched for many long hours and have found hundreds of users who posted the same exact problem, but no fixes that worked.

    Here's some more information. It happens mostly with SATA drives that use an onboard chipset via IDE\SATA dual mode. It is common to Kernel 2.6 and not limited to any linux flavour. All post were for SATA drives except for two who claimed to be using IDE drives.

    From what I take of the situation. SATA.i is not compatibel with the 2.6 kernels, or a configuration setting is missing that needs to be set. I will try some more things and check back here for more news. The problem has been going on since 2.6 kernel was tried with SATA drives and onboard controllers from what I can tell.

    THANKS
    John

Page 2 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •