Find the answer to your Linux question:
Page 4 of 4 FirstFirst 1 2 3 4
Results 31 to 40 of 40
I read /usr/doc/mkinitrd-1.0.1/README.initrd 10 times by now and made as many initrd. I use mkinitrd -c -m reiserfs -f reiserfs -r /dev/sda2 and it makes the initrd-tree, populates the two ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #31
    Just Joined!
    Join Date
    Feb 2006
    Posts
    51

    I read /usr/doc/mkinitrd-1.0.1/README.initrd 10 times by now and made as many initrd. I use

    mkinitrd -c -m reiserfs -f reiserfs -r /dev/sda2

    and it makes the initrd-tree, populates the two files with the reiserfs as root filesystem and /dev/sda2 as root dev, and loads the module reiserfs in the proper place.
    I have all this and the lilo.conf is correct and it still says kernel panic.

  2. #32
    Just Joined!
    Join Date
    May 2006
    Posts
    8
    Ok. Let's think that initrd - wrong way.
    Did you try built-in reiserfs in kernel?

  3. #33
    Just Joined!
    Join Date
    Feb 2006
    Posts
    51
    No because it looks difficult. Once I tried to compile a kernel and found out i had to know much more to do that. I will mess all up and I will not be able to find the wrong part. If I am to change a few things it is ok. So is there default options in the kernel that I can use? For the things I don't want to change?
    And another thing what exactly I have to add to the kernel - reiserfs support? Isn't that build-in in 2.6 kernel?

  4. #34
    Just Joined!
    Join Date
    May 2006
    Posts
    8
    Ok, ok.
    Third way - use pre-compiled kernel that you can upgrade via 'slapt-get'.
    As I knew - default FS in kernel - ext2 and (may be) ext3.

  5. #35
    Just Joined!
    Join Date
    Feb 2006
    Posts
    51
    Thanks but I already compiled a kernel . It is not working may be because I compiled so many things in it . Now I can see Lilo's choices and can reach XP. If I try to start Slack the screen turns black and there is a moving picture something like "Hz=? ". I tried to change LILO's setting but I am quite sure that the problem is in the kernel. there is no BIOS check or anything. I had that error once and it turned out to be video driver problem - I have ASSUS ATI EAX600pro. When I downloaded driver from ATI's web site it run ok. Am I to compile this driver into the kernel too?

  6. #36
    Just Joined!
    Join Date
    May 2006
    Posts
    8
    Can you write all that you see at screen when you choose Slack? Or make photo and put here? I can't inentify problem

  7. #37
    Just Joined!
    Join Date
    Feb 2006
    Posts
    51
    This is some kind of a drawing of that symbol moving on the screen.
    But I was wrong - First it is making BIOS check (ok) and after that it shows that symbol. I am pretty sure it is a display problem but I don't know where to look.
    Attached Images Attached Images

  8. #38
    Just Joined!
    Join Date
    May 2006
    Posts
    8
    Ough... may be I understand.
    It can be if you choose non-standart resolution for booting into Slack and monitor can't make refresh.
    If you wish, I can post my lilo.conf here (I boot with 1024x768 in text and 1280x1024 in Xorg)

  9. #39
    Just Joined!
    Join Date
    Jun 2006
    Posts
    2

    Device /dev/sda does not exist

    Thats for all the prior directions. Was able to get Slack linux to boot using libata. But now my device /dev/sda does not exist. This makes it impossible for me to compile my kernel without going to a boot cd and setting dma with hdparm. Please help.

    dmesg output

    Linux version 2.6.17 (root@mfleming-mbl) (gcc version 3.3.6) #7 SMP Fri Jun
    Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
    pnp: the driver 'ide' has been registered
    GDT-HA: Storage RAID Controller Driver. Version: 3.04
    GDT-HA: Found 0 PCI Storage RAID Controllers
    libata version 1.20 loaded.
    ata_piix 0000:00:1f.2: version 1.05
    ata_piix 0000:00:1f.2: MAP [ P0 P2 IDE IDE ]
    ACPI: PCI Interrupt 0000:00:1f.2[B] -> GSI 19 (level, low) -> IRQ 19
    PCI: Setting latency timer of device 0000:00:1f.2 to 64
    ata1: SATA max UDMA/133 cmd 0x1F0 ctl 0x3F6 bmdma 0x18B0 irq 14
    ata1: dev 0 cfg 49:0f00 82:746b 83:7f69 84:6063 85:f469 86:3d49 87:6063 88:203f
    ata1: dev 0 ATA-7, max UDMA/100, 156301488 sectors: LBA48
    ata1: dev 0 configured for UDMA/100
    scsi0 : ata_piix
    Vendor: ATA Model: HTS541080G9SA00 Rev: MB4I
    Type: Direct-Access ANSI SCSI revision: 05
    ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0x18B8 irq 15
    ata2: dev 0 cfg 49:0f00 82:421c 83:0000 84:0000 85:0000 86:0000 87:0000 88:0407
    ata2: dev 0 ATAPI, max UDMA/33
    ata2: dev 0 configured for UDMA/33
    scsi1 : ata_piix
    Vendor: HL-DT-ST Model: DVDRAM GMA-4082N Rev: HA01
    Type: CD-ROM ANSI SCSI revision: 05
    SCSI device sda: 156301488 512-byte hdwr sectors (80026 MB)
    sda: Write Protect is off
    sda: Mode Sense: 00 3a 00 00
    SCSI device sda: drive cache: write back
    SCSI device sda: 156301488 512-byte hdwr sectors (80026 MB)
    sda: Write Protect is off
    sda: Mode Sense: 00 3a 00 00
    SCSI device sda: drive cache: write back
    sda: sda1 sda2
    sd 0:0:0:0: Attached scsi disk sda
    sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
    Uniform CD-ROM driver Revision: 3.20
    sr 1:0:0:0: Attached scsi CD-ROM sr0
    sd 0:0:0:0: Attached scsi generic sg0 type 0
    sr 1:0:0:0: Attached scsi generic sg1 type 5
    ACPI: PCI Interrupt 0000:00:1d.7[A] -> GSI 23 (level, low) -> IRQ 20
    PCI: Setting latency timer of device 0000:00:1d.7 to 64
    ehci_hcd 0000:00:1d.7: EHCI Host Controller
    ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 1
    ehci_hcd 0000:00:1d.7: debug port 1
    PCI: cache line size of 32 is not supported by device 0000:00:1d.7
    ehci_hcd 0000:00:1d.7: irq 20, io mem 0xb0004000
    ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004

    md: raid0 personality registered for level 0
    md: raid1 personality registered for level 1
    md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
    md: bitmap version 4.39

    md: Autodetecting RAID arrays.
    md: autorun ...
    md: ... autorun DONE.
    EXT2-fs warning (device sda2): ext2_fill_super: mounting ext3 filesystem as ext2
    VFS: Mounted root (ext2 filesystem) readonly.

  10. #40
    Just Joined!
    Join Date
    Jun 2006
    Posts
    2

    Temp Solution

    Found a temp solution.
    Used mknode to create the devices sda and sda1. Fdisk works and give me back the proper disk info. Hope it stays after reboot.

Page 4 of 4 FirstFirst 1 2 3 4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •