Find the answer to your Linux question:
Results 1 to 6 of 6
Hello all, Similar to an earlier posting, after updating my system with swaret, alsa does not function properly. I can issue the command alsaconf and I am able to choose ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    6

    ALSA broken


    Hello all,

    Similar to an earlier posting, after updating my system with swaret, alsa does not function properly. I can issue the command alsaconf and I am able to choose the correct module for my sound card. However, when attempting to run alsamixer I get the following message:

    alsamixer: function snd_ctl_open failed for default: No such file or directory

    When attempting to run alsactl store, I receive the following:

    alsactl: save_state:1163: No soundcards found...

    I have upgraded all the necessary alsa packages manually, and still to no avail. I have recompiled the kernel (2.6.12.3) without any success either. If you are able to offer me any suggestions, it would be much appreciated. Thank you.

  2. #2
    Just Joined!
    Join Date
    Jul 2005
    Posts
    7
    I don't have any clue, actually (about anything), but I had the same problem, and I had to compile the sound card drivers as modules. It wouldn't work if I compiled them into the kernel. I got some sound/Alsa related error messages at boot, because Alsa couldn't find the modules it was looking for. Also, I've got Intel High Definition audio on board with a Realtek chip, but for some reason I had to enable some VIA AC'97 drivers to get things working.

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Posts
    6
    I have the sound card drivers configured as modules also, and they worked fine before I ran swaret yesterday. When I run alsaconf my sound card is seen, but I am still unable to get any sound.

  4. #4
    Linux Newbie
    Join Date
    Jan 2004
    Location
    UK
    Posts
    131
    i overcame that problem just today realizing that (in my box) was a matter of permission - could never hear anything logged in as user - as soon as i logged as root the sound magically appeared - PCI sound coard is loaded into the kernel and i can run alsamixer but not alsaconf (guess cos it's a static module) -

    anyway try to log in as root (if you havent done that already) and by the way if you figure out what the permission is to be able to hear sound as user ... let me know, pls!
    If you get on the wrong train all the stations you will come to will be the wrong stations.
    Zen

  5. #5
    Just Joined!
    Join Date
    Jul 2005
    Posts
    1
    @operator - you may want to try to issue the following as root user:

    chmod 777 /dev/audio
    chmod 777 /dev/mixer

    That should enable you to have sound as a normal user.

    @swampdog - Try to log in as root user and see if you can get sound to function properly, if it works as root you may need to issue the above commands as well.

  6. #6
    Just Joined!
    Join Date
    Jul 2005
    Posts
    6
    The errors that I have been receiving with alsa are when I am logged in as root. Everything wwas fine until I ran swaret, but I don't know exactly how it could have broken the sound that I had. Still trying to find a solution to this. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •