Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Problem with onboard NIC

    I am running Slackware 10.1 with the 2.4.29 kernel. The kernel is referred to as "vmlinuz" in /usr/src/linux.

    So I need to use the sk98lin driver for my onboard NIC. Well the NIC goes undetected when I load this module. I install the latest sk98lin driver and load it with modprobe. The module indeed loads but the NIC is still undetected. So I decide to make a patch for the kernel with the sk98lin driver floppy. I patch the kernel reload the module and recompile the kernel. Still no dice. So finally I load the module, re-compile my kernel from the ground up making the sk98lin module loadable and install the module permanently into the kernel, I install the kernel and point Lilo at it, reboot and still no dice. When I reboot not only does my module fail to load but it cant even be found. When I manually reload it from the floppy the module loads but cant see the NIC, and the module will stay loaded until I reboot then it is lost. When I do a ls /proc/net I can see it loaded there, but only if I load it with modprobe. The module does not load, or even exist upon boot. And even if it did it wouldn't matter, because the NIC still isn't being detected with it loaded. I do not know what I am doing wrong or if I am missing any steps. First one to solve my problem gets a large beer on me.

    ls /proc/net/sk98lin shows eth0 and eth1 (even though I only have one NIC, so eth0 should be all I see)

    ifconfig only shows my local loopback address, it does not display my NIC

  2. #2
    Join Date
    May 2004
    arch linux
    I don't know what's wrong with your setup, but sk98lin works fine on my box with no modifications. I just enable the module and all works well at system boot. My network card is the Marvell Yukon if that's any help. I read somewhere the other day that there's another driver out that replaces sk98lin in some cases. If I come across it, I'll post back here.

  3. #3
    Yeah I also have the Marvell Yukon chip. It should work with the sk98lin but it doesn't. I know for sure that the NIC works though. I guess it's back to the drawing board.

  4. $spacer_open
  5. #4
    I switched NICs and all is fine. Thanks for all your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts