Find the answer to your Linux question:
Results 1 to 9 of 9
i have been trying to get my video card 3d drivers working and i noticed an error at boot up but could never find it i did however found where ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Enthusiast carlosponti's Avatar
    Join Date
    Dec 2004
    Location
    Oklahoma
    Posts
    560

    Video Card Problem


    i have been trying to get my video card 3d drivers working and i noticed an error at boot up but could never find it i did however found where i get this error in some log
    Code:
    agpgart: unable to determine aperture size.
    can anyone help me?

    i have a MSI KT6V with a Via KT600 chipset and an ATI 9000 Pro
    Blog
    Registered Linux user 396557

  2. #2
    Linux Enthusiast carlosponti's Avatar
    Join Date
    Dec 2004
    Location
    Oklahoma
    Posts
    560
    bump
    Blog
    Registered Linux user 396557

  3. #3
    Just Joined! LinuxBox420's Avatar
    Join Date
    Jan 2005
    Posts
    32
    Did you compile your kernel yourself or are you using the default 2.4.29 kernel? It sounds like your kernel isn't configured for the VIA chip.

  4. #4
    Linux Enthusiast carlosponti's Avatar
    Join Date
    Dec 2004
    Location
    Oklahoma
    Posts
    560
    yes i used the precompiled kernel. do i have to configure my kernel or can i install the precompiled 2.26 kernel. what are my options?

    what would i have to do to configure for a Via KT600 chipset for the AGPGart to work with it?
    Blog
    Registered Linux user 396557

  5. #5
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429
    Have you configured X? AFAIK aperture size is set in the bios... But I could be wrong . Anyway, if you've configured X, you should've set the amount of memory your graphics card has.
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

  6. #6
    Linux Enthusiast carlosponti's Avatar
    Join Date
    Dec 2004
    Location
    Oklahoma
    Posts
    560
    i know apeture size is set in the bios because i set it when i was working on performance tuning my vid card. but configuring X really doesnt come into play with the AGPGart not starting which i have read is due to KT600 chipset however i havent well until this thread why that was.
    Blog
    Registered Linux user 396557

  7. #7
    Linux Enthusiast carlosponti's Avatar
    Join Date
    Dec 2004
    Location
    Oklahoma
    Posts
    560
    does this sound right? i did some reading and it maybe that the 2.24 kernel is not working with the KT600 chipsets and that i need to switch to the 2.26.5 kernel.
    Blog
    Registered Linux user 396557

  8. #8
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,132
    The 2.6 kernel has much better hardware support than the 2.4 kernel in my experience. I wouldn't be surprised at all if this was the case.

  9. #9
    Just Joined!
    Join Date
    Oct 2004
    Posts
    15
    This ati product is fairly well supported by the DRI drivers.

    How to install DRI:
    **Compile kernel with:
    Loadable Modules support
    >*Enable Module Loading
    -->*Enable Module unloading
    Device Drivers
    >Character Devices
    -->*/dev/agpgart support
    ----->*Intel 440LX...
    ----->*Intel i865...
    ----->*ATI chipset
    ----->*Via (if available)???
    -->*Direct Rendering Manager
    ----->*ATI Radeon
    >Graphics support
    -->*ATi Radeon (NEW) (don't check the old driver.... you won't need it)


    **Compile [CVS] Mesa... freedesktop.org, mesa3d.sf.net
    **Compile [CVS] Xorg... freedesktop.org, x.org
    **Do xorgconfig
    .... follow along with all the options
    Edit /etc/X11/xorg.conf:
    In Modules section add
    Load "glx"
    Load "dri"
    Here is how a device section should look:
    Section "Device"
    Identifier "radeon"
    Driver "radeon"
    VideoRam 65536
    ChipId 0x514D
    # Insert Clocks lines here if appropriate
    EndSection


    Add the following section at the end:
    Section "DRI"
    Mode 0666
    EndSection


    startx and you should be ready.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •