Find the answer to your Linux question:
Results 1 to 5 of 5
on boot i see this message: " warning the dma on your hard drive is turned off this may really slow down the fsck process." how to turn on DMA ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    32

    DMA is turned off


    on boot i see this message: "
    warning the dma on your hard drive is turned off this may really slow down the fsck process." how to turn on DMA ?

  2. #2
    Linux Guru
    Join Date
    Nov 2004
    Posts
    6,110
    Code:
    hdparm -d1 /dev/hda
    Where /dev/hda is the disk you want to turn it on. It can also be set in /etc/sysconfig/harddisks if you have that file in your distro.

  3. #3
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    You might want to take a look here before you make any changes:

    http://www.faqs.org/docs/Linux-mini/Ultra-DMA.html#toc8

  4. #4
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    If you compiled your kernel you might have missed that option.
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  5. #5
    Linux User Krendoshazin's Avatar
    Join Date
    Feb 2005
    Location
    London, England
    Posts
    471
    You need to compile the proper support for your hard drive's chipset into the kernel, I've met this error before

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •