Find the answer to your Linux question:
Results 1 to 2 of 2
Hey guys: I'm hoping some has seen this before, but I cannot figure this one out., and I've looked elsewhere for a while now. I have this problem with my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    1

    Java installation problem


    Hey guys:

    I'm hoping some has seen this before, but I cannot figure this one out., and I've looked elsewhere for a while now.

    I have this problem with my current linux kernel 2.0.35, and an older one (can't remember what I had before.) Anyway, I have downloaded Java sdk 1.4.09 (and several older ones throughout the last year or so) and every time I run the self-extracting file (not the rpm version, but the other one), I only get a directory j2sdk1.4.2_09 and a few config files. I do not get the java binaries or any other java goodies I normally get, almost as if the installation doesn't complete.

    I know it doesn't work right, and I know the self-extracting file works because on one occasion I tried the EXACT SAME self-extracting install on Caldera and got the full Java sdk.

    Any help would be greatly appreciated.
    Thanks.

    -joel

  2. #2
    Linux Newbie
    Join Date
    Aug 2005
    Posts
    214
    These files you downloaded are source archives. Ones you extract them, you have to, generally, run "./configure", "make" and "make install" (last one as root) in order to prepare your configuration scripts, compile sources and install binaries.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •