Find the answer to your Linux question:
Results 1 to 2 of 2
Morning for everyone First, I'll have to pass some hardware info. My motherboard is an Asus A7N8X-X (NForce2 Chipset). At Slack 10.1 (with both kernel 2.4.29 or 2.4.31) I had ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    5

    Problem migratin from kernel 2.4.x to 2.6.x


    Morning for everyone
    First, I'll have to pass some hardware info. My motherboard is an Asus A7N8X-X (NForce2 Chipset).
    At Slack 10.1 (with both kernel 2.4.29 or 2.4.31) I had to download the modules from Nvidia site so that I could make my net and sound work.

    I went to kernel 2.6.10 included with the second disc and got it up, but one thing I noticed: if I try a netconfig and probe for the netcard, it will show a 3c59x (actually, since the first boot with the 2.6 kernel, my system started to load that module, even before the netconfig).
    The problem is that my ADSL won't work anymore.

    If tried to run adsl-setup again, but as expected, it didn't work.
    Running adsl-start would show the following error at dmesg:

    "divert: not allocating divert_blk for non-ethernet device ppp0
    divert: no divert_blk to free, ppp0 not ethernet"

    If I got it right, it says that the interface ppp0 is not connected to my NIC in anyway.
    I tried installing the modules from Nvidia, but I got a series of errors.
    I download kernel 2.6.12.5 from kernel.org, but there was no change at all.

    Anyone has ever seen something like that before?
    Thanks

  2. #2
    Just Joined!
    Join Date
    Aug 2005
    Posts
    11
    Im having a problem like yours, and, btw, ppp0 isnt the ethernet controler to be used on adsl, instead use ethx, eth0 for example.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •