Find the answer to your Linux question:
Results 1 to 8 of 8
hi there, i am just new in this forum and this is my last resort...ive been asking question in lots of channels in irc regarding slackware my problem is that...i ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Location
    cebu city, philippines
    Posts
    5

    probing problem


    hi there, i am just new in this forum and this is my last resort...ive been asking question in lots of channels in irc regarding slackware

    my problem is that...i am using a modem router and then during the installation process in my machine i have to use SCSI.S in booting the kernel in the start of installation...and then the problem is my lancard will only be detected if i'll answer YES in the hotplugging question during the installation but if i will answer NO it wont detect my lancard...and then after the installation is finish...and then i will boot the slackware... it will just hang up in the cheking of syslog -3 something like that

    i've tried installing slackware before and they all worked fine but here in my pc now...it really has alot of problem like in HOTPLUGING in PROBING i dunno if this is because of the incompatibility of my board or my hardware!

    hope to have a reply soon! thanks in advance guys!

  2. #2
    Linux Newbie
    Join Date
    Jan 2004
    Location
    Belgrade, S&M
    Posts
    177
    Well then, choose not to load hotplug at start-up. When you need your lan card, start hotpluging manualy:
    Code:
    chmod +x /etc/rc.d/rc.hotplug
    /etc/rc.d/rc.hotplug start
    If it reports an error then it is probably a resource conflict.

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Location
    cebu city, philippines
    Posts
    5
    I've tried your suggestion...and it gives me this error

    ERROR:
    root@jupenz:/etc/apache# /etc/rc.d/rc.hotplug start
    ./hotplug.functions: line 127: 1014 Segmentation fault $MODPROBE $MODULE >/dev/null 2>&1

    all i want is to make the slackware detect my lancard so that i can connect to the internet

  4. #4
    Linux Newbie
    Join Date
    Jan 2004
    Location
    Belgrade, S&M
    Posts
    177
    What lan card do you have ? Try loading the drivers yourself with modprobe and bringing the card up. Do you know which module you are suppose to load I My card is supported by the module eepro100 so I do something like this:

    Code:
    modprobe eepro100
    ifconfig eth0 192.168.2.1 up
    ping 192.168.2.1

  5. #5
    Just Joined!
    Join Date
    Aug 2005
    Location
    cebu city, philippines
    Posts
    5
    root@jupenz:~# lsmod
    Module Size Used by Not tainted
    8139too 13928 1 (initializing)
    mii 2272 0 [8139too]
    crc32 2880 0 [8139too]
    ide-scsi 9392 0
    agpgart 45092 0 (unused)
    root@jupenz:~#

    ive tried modprobe 8139too
    and then i have that result but the problem is when i tried to use ifconfig eth0 or ifconfig it hanged up and i dunno if the result is just being delayed i dunno...maybe something wrong with it!

  6. #6
    Just Joined!
    Join Date
    Aug 2005
    Location
    cebu city, philippines
    Posts
    5
    I tried using a non onboard ethernet card but the problem is... it will hang`up on probing! can anyone help me about this? why im using Intel(R) PRO/100b pci lancard...i dunno why it hanged`up

  7. #7
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    You're loading the wrong driver I think

    the intel isnt a realtek chipset for a start

    try this:

    Code:
    modprobe eepro100
    if you want to check you have the module first

    Code:
    modprobe -l | grep eepro100
    if you want to find out some options about it

    Code:
    modinfo eepro100
    check the output of the 'dmesg' command to see what it says after loading the module, then configure the device with ifconfig or netconfig.


  8. #8
    Just Joined!
    Join Date
    Aug 2005
    Location
    cebu city, philippines
    Posts
    5
    ok here's what i did

    root@Slackware:~# modprobe eepro100 <--- first i did this
    Segmentation fault

    root@Slackware:~# lsmod <---- second
    Module Size Used by Not tainted
    eepro100 18836 1 (initializing)
    mii 2272 0 [eepro100]
    soundcore 3396 0 (autoclean)
    ide-scsi 9392 0
    agpgart 45092 0 (unused)
    root@Slackware:~#

    and then when i try to dmesg here's the info

    Linux version 2.4.29 (root@midas) (gcc version 3.3.4) #6 Thu Jan 20 16:30:37 PST 2005
    BIOS-provided physical RAM map:
    BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
    BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
    BIOS-e820: 00000000000d0000 - 00000000000d80ac (reserved)
    BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
    BIOS-e820: 0000000000100000 - 000000001fff0000 (usable)
    BIOS-e820: 000000001fff0000 - 000000001fff8000 (ACPI data)
    BIOS-e820: 000000001fff8000 - 0000000020000000 (ACPI NVS)
    BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
    BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
    BIOS-e820: 00000000ffb00000 - 00000000ffc00000 (reserved)
    BIOS-e820: 00000000fff00000 - 0000000100000000 (reserved)
    511MB LOWMEM available.
    On node 0 totalpages: 131056
    zone(0): 4096 pages.
    zone(1): 126960 pages.
    zone(2): 0 pages.
    Kernel command line: BOOT_IMAGE=Linux ro root=341 hdc=ide-scsi
    ide_setup: hdc=ide-scsi
    Initializing CPU#0
    Detected 2392.359 MHz processor.
    Console: colour dummy device 80x25
    Calibrating delay loop... 4771.02 BogoMIPS
    Memory: 515348k/524224k available (1831k kernel code, 8488k reserved, 607k data, 120k init, 0k highmem)
    Dentry cache hash table entries: 65536 (order: 7, 524288 bytes)
    Inode cache hash table entries: 32768 (order: 6, 262144 bytes)
    Mount cache hash table entries: 512 (order: 0, 4096 bytes)
    Buffer cache hash table entries: 32768 (order: 5, 131072 bytes)
    Page-cache hash table entries: 131072 (order: 7, 524288 bytes)
    CPU: Trace cache: 12K uops, L1 D cache: 16K
    CPU: L2 cache: 1024K
    CPU: After generic, caps: bfebfbff 00000000 00000000 00000000
    CPU: Common caps: bfebfbff 00000000 00000000 00000000
    CPU: Intel(R) Pentium(R) 4 CPU 2.40GHz stepping 01
    Enabling fast FPU save and restore... done.
    Enabling unmasked SIMD FPU exception support... done.
    Checking 'hlt' instruction... OK.
    POSIX conformance testing by UNIFIX
    mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
    mtrr: detected mtrr type: Intel
    PCI: PCI BIOS revision 2.10 entry at 0xfdb51, last bus=3
    PCI: Using configuration type 1
    PCI: Probing PCI hardware
    PCI: Probing PCI hardware (bus 00)
    PCI: Ignoring BAR0-3 of IDE controller 00:1f.1
    Transparent bridge - Intel Corp. 82801BA/CA/DB/EB PCI Bridge
    PCI: Using IRQ router PIIX/ICH [8086/24c0] at 00:1f.0
    PCI: Found IRQ 5 for device 00:1f.1
    PCI: Sharing IRQ 5 with 00:1d.2
    Linux NET4.0 for Linux 2.4
    Based upon Swansea University Computer Society NET3.039
    Initializing RT netlink socket
    Starting kswapd
    VFS: Disk quotas vdquot_6.5.1
    Journalled Block Device driver loaded
    vesafb: framebuffer at 0xc0000000, mapped to 0xe080d000, size 1536k
    vesafb: mode is 1024x768x8, linelength=1024, pages=3
    vesafb: protected mode interface info at c000:e4d0
    vesafb: scrolling: redraw
    Console: switching to colour frame buffer device 128x48
    fb0: VESA VGA frame buffer device
    pty: 512 Unix98 ptys configured
    Serial driver version 5.05c (2001-07-0 with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI enabled
    ttyS00 at 0x03f8 (irq = 4) is a 16550A
    Real Time Clock Driver v1.10f
    Floppy drive(s): fd0 is 1.44M
    FDC 0 is a post-1991 82077
    RAMDISK driver initialized: 16 RAM disks of 7777K size 1024 blocksize
    loop: loaded (max 8 devices)
    Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
    ICH4: IDE controller at PCI slot 00:1f.1
    PCI: Found IRQ 5 for device 00:1f.1
    PCI: Sharing IRQ 5 with 00:1d.2
    ICH4: chipset revision 2
    ICH4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xfc00-0xfc07, BIOS settings: hdaMA, hdbMA
    ide1: BM-DMA at 0xfc08-0xfc0f, BIOS settings: hdcMA, hddMA
    hda: SAMSUNG SP0411N, ATA DISK drive
    hdb: ST340014A, ATA DISK drive
    blk: queue c03ad460, I/O limit 4095Mb (mask 0xffffffff)
    blk: queue c03ad59c, I/O limit 4095Mb (mask 0xffffffff)
    hdc: ASUS CRW-5232AX, ATAPI CD/DVD-ROM drive
    hdd: SAMSUNG CD-ROM SH-152A, ATAPI CD/DVD-ROM drive
    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    ide1 at 0x170-0x177,0x376 on irq 15
    hda: attached ide-disk driver.
    hda: host protected area => 1
    hda: 78242976 sectors (40060 MB) w/2048KiB Cache, CHS=4870/255/63, UDMA(100)
    hdb: attached ide-disk driver.
    hdb: host protected area => 1
    hdb: 78165360 sectors (40021 MB) w/2048KiB Cache, CHS=4865/255/63, UDMA(100)
    hdd: attached ide-cdrom driver.
    hdd: ATAPI 52X CD-ROM drive, 128kB Cache, UDMA(33)
    Uniform CD-ROM driver Revision: 3.12
    Partition check:
    hda: hda1 hda2 < hda5 hda6 >
    hdb: hdb1 hdb2 < hdb5 >
    SCSI subsystem driver Revision: 1.00
    kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
    kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
    kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
    md: linear personality registered as nr 1
    md: raid0 personality registered as nr 2
    md: raid1 personality registered as nr 3
    md: raid5 personality registered as nr 4
    raid5: measuring checksumming speed
    8regs : 2617.200 MB/sec
    32regs : 1757.200 MB/sec
    pIII_sse : 4098.800 MB/sec
    pII_mmx : 2589.200 MB/sec
    p5_mmx : 2597.600 MB/sec
    raid5: using function: pIII_sse (4098.800 MB/sec)
    md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
    md: Autodetecting RAID arrays.
    md: autorun ...
    md: ... autorun DONE.
    LVM version 1.0.8(17/11/2003)
    Initializing Cryptographic API
    NET4: Linux TCP/IP 1.0 for NET4.0
    IP Protocols: ICMP, UDP, TCP, IGMP
    IP: routing cache hash table of 4096 buckets, 32Kbytes
    TCP: Hash tables configured (established 32768 bind 65536)
    Linux IP multicast router 0.06 plus PIM-SM
    NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
    kjournald starting. Commit interval 5 seconds
    EXT3-fs: mounted filesystem with ordered data mode.
    VFS: Mounted root (ext3 filesystem) readonly.
    Freeing unused kernel memory: 120k freed
    EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,65), internal journal
    Linux agpgart interface v0.99 (c) Jeff Hartmann
    agpgart: Maximum main memory to use for agp memory: 439M
    agpgart: Detected an Intel(R) 845G Chipset.
    agpgart: No pre-allocated video memory detected.
    agpgart: AGP aperture is 128M @ 0xd0000000
    hdc: attached ide-scsi driver.
    scsi0 : SCSI host adapter emulation for IDE ATAPI devices
    Vendor: ASUS Model: CRW-5232AX Rev: 1.01
    Type: CD-ROM ANSI SCSI revision: 02
    Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
    sr0: scsi3-mmc drive: 52x/52x writer cd/rw xa/form2 cdda tray
    eepro100.c:v1.09j-t 9/29/99 Donald Becker http://www.scyld.com/network/eepro100.html
    eepro100.c: $Revision: 1.36 $ 2000/11/17 Modified by Andrey V. Savochkin <saw@saw.sw.com.sg> and others
    PCI: Found IRQ 5 for device 03:04.0
    PCI: Sharing IRQ 5 with 00:1f.5
    Unable to handle kernel paging request at virtual address 1f68c005
    printing eip:
    c011bd99
    *pde = 00000000
    Oops: 0000
    CPU: 0
    EIP: 0010:[<c011bd99>] Not tainted
    EFLAGS: 00210202
    eax: 1f68c001 ebx: cd7fffff ecx: cd7ff000 edx: c031955c
    esi: d3854a60 edi: c0002014 ebp: cd7ff000 esp: d30e5e94
    ds: 0018 es: 0018 ss: 0018
    Process modprobe.old (pid: 593, stackpage=d30e5000)
    Stack: d3854a60 c031955c d3854a7c c011c007 c031955c d3854a60 dffe2c00 00000001
    dffe2c00 00000000 e0a2f0fc c031955c cd7ff000 00001000 e0a332d0 dffe2c00
    e0a33620 e0a33960 dffe2c00 00000000 c0233031 dffe2c00 e0a33620 dffe2c00
    Call Trace: [<c011c007>] [<e0a2f0fc>] [<e0a332d0>] [<e0a33620>] [<e0a33960>]
    [<c0233031>] [<e0a33620>] [<e0a33960>] [<c02330c7>] [<e0a33960>] [<e0a32229>]
    [<e0a33960>] [<c01186e0>] [<e0a33520>] [<e0a2f060>] [<c0108a93>]

    Code: 39 58 04 77 0a 39 48 08 8d 78 14 72 ed eb d8 89 46 14 31 c0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •