Find the answer to your Linux question:
Results 1 to 9 of 9
I have an NTFS HDD that contains all my music and I was pretty pissed when I couldn't access it from my user, but I can access it with ease ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    33

    Permissions


    I have an NTFS HDD that contains all my music and I was pretty pissed when I couldn't access it from my user, but I can access it with ease under root.

    I have been told that it was the permissions that haven't been set onto my user to access the drive.

    I am running slackware 10.1, using fluxbox.

    anyone can help?

  2. #2
    Linux Engineer
    Join Date
    Aug 2004
    Posts
    826
    Code:
    $ man fstab
    $ man umask
    $ man chmod
    Basically, you'll need to edit /etc/fstab and add/edit the entry for your windows partition and include the mount option umask=0444 which will allow reading by all.

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Posts
    33
    Quote Originally Posted by sether
    Code:
    $ man fstab
    $ man umask
    $ man chmod
    Basically, you'll need to edit /etc/fstab and add/edit the entry for your windows partition and include the mount option umask=0444 which will allow reading by all.
    how do i do that? where do i put that?

    Code:
    /dev/hda1        /                reiserfs    defaults         1   1
    /dev/hdb2        /win1            ntfs        ro,users         1   0
    /dev/hdb1        /win2            vfat        defaults         1   0
    /dev/cdrom       /mnt/cdrom       iso9660     noauto,owner,ro  0   0
    /dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
    devpts           /dev/pts         devpts      gid=5,mode=620   0   0
    proc             /proc            proc        defaults         0   0
    this is what my /etc/fstab looks like...

    p.s. i have my music playing atm because i used a terminal to start xmms under root. genius idea to me

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Sep 2005
    Posts
    140
    How you do this is a matter of preference. Here's one way;
    1) In a terminal type "kdesu kate" . I believe "kdesu kwrite" will also work.
    2) Call up your fstab file and make the edit. umask goes into the options column (where you see things like ro and users)
    3) You may have to reboot for the changes to take effect.

    BTW: Did you read the recommended man pages?
    WARNING: I may be telling you more than I know !

  6. #5
    Just Joined!
    Join Date
    Aug 2005
    Posts
    33
    Quote Originally Posted by googled first
    How you do this is a matter of preference. Here's one way;
    1) In a terminal type "kdesu kate" . I believe "kdesu kwrite" will also work.
    2) Call up your fstab file and make the edit. umask goes into the options column (where you see things like ro and users)
    3) You may have to reboot for the changes to take effect.

    BTW: Did you read the recommended man pages?
    recommended man pages?

    anyway, ill try that.

  7. #6
    Linux Newbie
    Join Date
    Sep 2005
    Posts
    140
    recommended man pages?
    Reread this thread sometime down the road. The answer is looking right at you.
    Sort of offtopic: A few months ago I installed linux for the first time. I knew there was a cribbage game installed. Clicked all over the place looking for it. Had a good laugh at myself when I finally figured it out. You will probably have a lot of similar experiences. Linux is like that.
    Best of luck!
    WARNING: I may be telling you more than I know !

  8. #7
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    The answer is looking right at you.
    And I'm sure Spyro_boy appreciates your pointing this out.

    Spyro_boy, when sether wrote:
    • $ man fstab
      $ man umask
      $ man chmod
    he was suggesting that you enter those commands at the command line in a terminal. The '$' is meant to indicate the command prompt for the normal user. 'man' is the command for opening the manual pages for the command indicated. 'man fstab' of course has some information about the /etc/fstab file. The purpose for the fstab file is basically to tell Linux how to mount the various filesystems so 'man mount' has even more useful information.

    Quote Originally Posted by sether
    Basically, you'll need to edit /etc/fstab and add/edit the entry for your windows partition and include the mount option umask=0444 which will allow reading by all.
    So after looking at the man pages (more like a paragraph) for 'umask', you will probably want to open your /etc/fstab in an editor to make the change. You should have some editor you can click on in your GUI or you could try any one of these in a terminal: nano, pico, joe, kwrite, gedit. If all else fails, you can use vi, but you should definitly read the man pages for that first. From the terminal, the editor will be started with '$ nano /etc/fstab' (the $ is the command prompt so don't enter that, don't enter the quote marks, and substitute your preferred editor).

    It looks to me like you will want to change your "win1" line like so:
    Code:
    /dev/hdb2        /win1            ntfs        ro,users,umask=0444         1   0
    While you are in there, you might want to research whether the '1' near the end of that line belongs. I think it probably doesn't belong either on the win1 or the win2 line and should instead be '0', but I could be wrong. See 'man fstab'.
    /IMHO
    //got nothin'
    ///this use to look better

  9. #8
    Linux Newbie
    Join Date
    Sep 2005
    Posts
    140
    Okay I've been chastised and rightfully so. Spyro_boy, I apologise, my response was even worse than answering every question with RTFM.
    I should of told you to open a terminal and type "man man"
    If I was laughing at you, I was also laughing at me and the whole learning experience. Sometimes things in print come across differently than they do in person. I forgot that.
    Also my advice was rubbish. I assumed you were using Kde. Now I notice the reference to Fluxbox. The command "kdesu" probably wouldn't work.
    WARNING: I may be telling you more than I know !

  10. #9
    Just Joined!
    Join Date
    Aug 2005
    Posts
    33
    Quote Originally Posted by googled first
    Okay I've been chastised and rightfully so. Spyro_boy, I apologise, my response was even worse than answering every question with RTFM.
    I should of told you to open a terminal and type "man man"
    If I was laughing at you, I was also laughing at me and the whole learning experience. Sometimes things in print come across differently than they do in person. I forgot that.
    Also my advice was rubbish. I assumed you were using Kde. Now I notice the reference to Fluxbox. The command "kdesu" probably wouldn't work.
    oh haha! I get this now! thanks everyone, I will try this stuff and let you know if it worked. thanks for the help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •