Find the answer to your Linux question:
Results 1 to 2 of 2
my problem is that when issue this command.. shutdown -h now it will read and the last message is "Power Down" and i need to push the power button on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Location
    Mandaluyong
    Posts
    8

    problem with shutting down pc in slackware


    my problem is that when issue this command..

    shutdown -h now

    it will read and the last message is "Power Down" and i need to push the power button on my pc..

    what i want to do is that when i issue this command..

    shutdown -h now

    it will automatically shutdown my pc like in windows..

    i try to edit this file..Lilo.conf and add this line..

    append="acpi=power-off"

    and i also uncomment this

    /sbin/modprobe apm

    on rc.modules

    and run this..

    lilo -v

    but when i issue the command..

    shutdown -h now

    it gives the error message..

    general protection fault

    what should i do to solve this??
    any help will be much appreciated..
    thank you in advance..

  2. #2
    Just Joined!
    Join Date
    Aug 2004
    Location
    Croatia, Zagreb
    Posts
    70
    Maybe ACPI support isn't turned on in your kernel. When installing slackware you have an ability to choose an acpi enabled kernel to install which already has that option compiled.

    If you don't have that, then it could explain why it can't automatically be powered off.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •