Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
Slack 10.0 I have a vfat partition. fstab has /dev/hdb3 /mnt/music vfat auto,user,rw 1 0 It mounts at boot but will only allow root access. If root unounts and then ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305

    mount fstab problem


    Slack 10.0

    I have a vfat partition. fstab has

    /dev/hdb3 /mnt/music vfat auto,user,rw 1 0

    It mounts at boot but will only allow root access. If root unounts and then user mounts all is well.

    If I change to

    /dev/hdb3 /mnt/music vfat noauto,user,rw 1 0

    then user can mount quite happily and all is well.

    Any thoughts on why the auto mount selector stops me accessing the partition?
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  2. #2
    Linux Enthusiast aysiu's Avatar
    Join Date
    Jul 2005
    Posts
    633
    Try this in your /etc/fstab:

    Code:
    /dev/hdb3       /mnt/music  vfat    iocharset=utf8,umask=000   0       0

  3. #3
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    What gives with the iocharset option?
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  4. #4
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    I would try changing 'user' to 'users' and I think I'd try just using 'defaults' (does that not work with vfat?). As far as "thoughts on why the auto mount selector stops me accessing the partition?": can't help there, I just randomly try stuff 'til it works....
    /IMHO
    //got nothin'
    ///this use to look better

  5. #5
    Linux Enthusiast aysiu's Avatar
    Join Date
    Jul 2005
    Posts
    633
    Quote Originally Posted by Chris H
    What gives with the iocharset option? :?:
    I got it from here:

    http://ubuntuguide.org/#automountfat

    I followed those instructions, and it worked, so I'm not going to complain about the iocharset. I don't see why it wouldn't work for Slackware. /etc/fstabs shouldn't be distro-specific, as far as I know.

  6. #6
    Linux Newbie
    Join Date
    Sep 2005
    Posts
    140
    "and I think I'd try just using 'defaults' (does that not work with vfat?)"

    Apparently;
    /dev/hda1 /fat-c vfat defaults 1 0
    Works for me!
    WARNING: I may be telling you more than I know !

  7. #7

  8. #8
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    Ta all for the info and suggestions. I think I will leave it as noauto as it's working and I'm quite happy manually mounting devices.

    Cheers.
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  9. #9
    Just Joined!
    Join Date
    Oct 2006
    Posts
    2

    Newbie question

    I have mounted linux fedora onto winxp and also edited fstab so that it starts up fine... i can see the windows drive and its folder content, however when i am in linux it does not allow me to write or change any of the files in the newly created folder... i have tried changing permissions in the user(with root rights) and root accounts but it still does not allow the permissions to be changed.

    The only way around this prob is if i log into the root account and drag folders around but this is a hassle...there must be a simpler way.

    How can I save files in the shared folder i have created? has it got anything to do with fstab?
    Please help..as this is getting frustrating

  10. #10
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    its very simple......
    log in as 'root' and open /etc/fstab file...
    change value of umask=0 for all the windows partitions listed in fstab...
    a standard line for FAT32 windows partition is ...

    /dev/hdx /media/mount_point vfat rw,defaults,umask=0 0 0

    here x is partition number......
    now all users will have read/write permissions in Windows FAT32 partitions.




    casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •