Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
Sound server informational message: Error while initializing the sound driver: device /dev/dsp can't be opened (No such device) The sound server will continue, using the null output device. i have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    98

    no sound


    Sound server informational message:
    Error while initializing the sound driver:
    device /dev/dsp can't be opened (No such device)
    The sound server will continue, using the null output device.

    i have no idea where to get linux sound drivers from for my MOBO, i have MSI K8N Neo4

  2. #2
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    you need to find out your sound chipset, you can use lspci to find out which one it is, then visit the alsa project's homepage, find it in the matrix, and follow the tutorial.
    Operating System: GNU Emacs

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    98
    i am having some problems w/ the setup

    7. Edit your /etc/modules.conf (see the kmod support section below).
    i cant find a kmod section on the instructions

    8. Run 'modprobe snd-xxxx' where xxxx is the name of your card.
    from lspci command i got: '00:04.0 Multimedia audio controller: nVidia Corporation: Unknown device 0059 (rev a2)' so would i put 0059 where the x's r? if so i did that and i got : 'modprobe: Can't locate module snd-0059' but i didnt edit /etc/modules.conf b4 doing this, cuz i dont know wat to do w/ it

  4. #4
    Just Joined!
    Join Date
    Sep 2005
    Posts
    12
    it's a NForce chipset.

    goto nvidia.com and download the nforce driver for linux then run the installation.

    Reboot and voila...you should have sound (and internet if you use the onboard ethernet adapter)

  5. #5
    Just Joined!
    Join Date
    Nov 2004
    Location
    on the WAN
    Posts
    25
    Quote Originally Posted by phirexx

    goto nvidia.com and download the nforce driver

    Reboot and voila...you should have ... internet if you use the onboard ethernet adapter...

  6. #6
    Just Joined!
    Join Date
    Jun 2005
    Posts
    4

    Slackware sound

    for an nforce chipset try something like
    modprobe snd_intel8x0 for a nforce sound.

    At one point I was gong to install the nforce drivers but noticed that it is
    based on the older OSS sound system so I stuck with the intel which in most
    (newer) cases regonizes the nforce sound system, plus it uses ALSA which
    most modern applicatins expect these days. Also sound seems to work better for me with my nforce chhip set if I use thw 2.6 kernel. For the eth drivers forcedeth works.

  7. #7
    Just Joined!
    Join Date
    Mar 2005
    Posts
    98
    from here: http://nvidia.com/content/drivers/drivers.asp, wat options do i need 2 pick

  8. #8
    Just Joined!
    Join Date
    Sep 2005
    Posts
    12
    click on Linux, FreeBSD, and Solaris Drivers

    and select the NForce driver you need...either 64 or 32 bit depending on your processor.

    then type at a terminal:

    Code:
    sudo sh NFORCE-Linux-x86-1.0-0306-pkg1.run
    or (depending on your processor)
    Code:
    sudo sh NFORCE-Linux-x86_64-1.0-0306-pkg1.run
    then reboot and you should then have sound.

  9. #9
    Just Joined!
    Join Date
    Mar 2005
    Posts
    98
    Code:
    sh-3.00$ sudo sh NVIDIA-Linux-ia64-1.0-5336-pkg1.run
    
    We trust you have received the usual lecture from the local System
    Administrator. It usually boils down to these three things:
    
        #1) Respect the privacy of others.
        #2) Think before you type.
        #3) With great power comes great responsibility.
    
    Password:
    i tried typing in my root password but that didnt work, what password is it talking about????

  10. #10
    Just Joined!
    Join Date
    Apr 2005
    Location
    /usr/home/slith
    Posts
    93
    To use sudo you mus configure the sudoers file, but it is easier to just log in as root and do what you need to...

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •