Find the answer to your Linux question:
Results 1 to 9 of 9
alsamixer has to be re ran everytime I reboot. I run alsactl store and have /usr/sbin/alsactl restore added to my rc.local file, but my settings go back to being default ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    84

    alsamixer wont save settings


    alsamixer has to be re ran everytime I reboot. I run alsactl store and have /usr/sbin/alsactl restore added to my rc.local file, but my settings go back to being default (muted) upon boot. I suspect I have to re-run alsamixer because I have an entry in my rc.local file to re-run ./snddevices at boot as well, which is probably reconfiguring my card. This the only way I have been able to get sound to work (the ./snddevices thing), and trust me. I have been all over lots of forums, and I have tried everything. It's been the only way that works for me. I am running Slackware 10.1 with kernel 2.6.13.2

  2. #2
    Banned
    Join Date
    Nov 2004
    Location
    Belgium
    Posts
    1,120
    run alsaconf as root (should do everything for you)

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Posts
    84
    Running alsaconf does not help aid me in the saving of my alsamixer settings, even if ran as root. Thank you for your reply however.

  4. #4
    Just Joined!
    Join Date
    Sep 2005
    Posts
    12
    Code:
    alsactl store
    should keep them settings.

  5. #5
    Just Joined!
    Join Date
    Jul 2005
    Posts
    84
    BrunoM

    The first line of my post states that I tried that.

  6. #6
    Just Joined!
    Join Date
    Aug 2004
    Location
    Kentucky
    Posts
    20
    Comment out the line for ./snddevices in rc.local.
    Re-run alsaconf, alsamixer, and alsctl store as root in that order. Reboot - you should be ok.

  7. #7
    Just Joined!
    Join Date
    Jul 2005
    Posts
    84
    That wont work, the whole reason I have that in their is because alsamixer wont run until I run ./snddevices. That is what makes my card work. Alsaconf will still find my card but the card wont function until I run snddevices.

  8. #8
    Just Joined!
    Join Date
    Aug 2004
    Location
    Kentucky
    Posts
    20
    I just noticed that you are using kernel 2.6.13 - you may need to get a newer version of alsa for this kernel. I am using 2.6.12 with no problems with 10.2.

    I do not have that line in rc.local. I am using an old sounblaster pci 128. Works great.

  9. #9
    Banned
    Join Date
    Nov 2004
    Location
    Belgium
    Posts
    1,120
    see: http://alsa.opensrc.org/faq/#FAQ021
    There's several ways to fix this. The easiest is to write a script with one line:

    alsactl restore

    , save it as 'alsasoundrestoremixer' in /etc/init.d/, make it executable:

    % chmod a+x /etc/init.d/alsasoundrestoremixer

    , and create a symlink to run this straight after alsasound:

    % ln -s /etc/init.d/alsasoundrestoremixer /etc/rcS.d/S59alsasoundrestoremixer

    This forces the loading of the mixer settings every time the system is booted.
    PS: You might need to include whatever else you need to do to get it working...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •