Find the answer to your Linux question:
Results 1 to 7 of 7
OK, kern,bubo you may remember that i was going to do ACPI. Well, I compiled the 2.6.13.2 kernel yesterday and it works with ACPI. however I can't figure out where ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Apr 2005
    Location
    NJ, USA
    Posts
    104

    ACPI CPU frequency scaling


    OK, kern,bubo you may remember that i was going to do ACPI. Well, I compiled the 2.6.13.2 kernel yesterday and it works with ACPI. however I can't figure out where to find the script that lowers the CPU frequency when the system is not under load. I know it (the kernel) supports it

    Code:
    powernow-k8: Found 1 AMD Athlon 64 / Opteron processors (version 1.50.3)
    powernow-k8:    0 : fid 0x2 (1000 MHz), vid 0x12 (1100 mV)
    powernow-k8:    1 : fid 0xa (1800 MHz), vid 0xe (1200 mV)
    powernow-k8:    2 : fid 0xc (2000 MHz), vid 0xa (1300 mV)
    powernow-k8:    3 : fid 0xe (2200 MHz), vid 0x6 (1400 mV)
    powernow-k8:    4 : fid 0x10 (2400 MHz), vid 0x2 (1500 mV)
    cpu_init done, current fid 0x10, vid 0x2
    That is the bootup information of supported frequency scaling.
    maybe there is a script to scale the frequency?Any ideas
    My New years Resolution is 1280x1024

  2. #2
    Just Joined!
    Join Date
    Nov 2004
    Location
    WGS84 phi = 45 48 31.7 lambda = 15 57 49.0
    Posts
    65
    well it depends on what scaling governor is selected.

    u can select one by echoing name of governor to /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

    i have following lined in my /etc/rc.d/rc.local
    Code:
    echo Setting AMD Cool'n'Quiet....
    echo 'ondemand' > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    and of course u need to have Cool'n'Quiet enabled in BIOS

  3. #3
    Linux Newbie
    Join Date
    Apr 2005
    Location
    NJ, USA
    Posts
    104
    I beleive that i have it enabled it in the kernel......i will have some more info later..(my 2.6.13.2 kernel is currently broken).
    My New years Resolution is 1280x1024

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Apr 2005
    Location
    NJ, USA
    Posts
    104
    I got CPU frequency scaling working last night but this morning when i started up the computer it is bak to userspace. I dont think Slackware 10.1 has any userspace programs for that and i was wondering if i have to insert any modules
    My New years Resolution is 1280x1024

  6. #5
    Just Joined!
    Join Date
    Nov 2004
    Location
    WGS84 phi = 45 48 31.7 lambda = 15 57 49.0
    Posts
    65
    that is true, Slackware does not have any userspace programs for frequency scaling, so if u want to change it from 'userspace' u need to put those lines i worte before.

    Also make sure u loaded other scaling governors, best thing to do is to include them in kernel, so no modules.

    And u can always download som userspace program to control it for you!

  7. #6
    Linux Newbie
    Join Date
    Apr 2005
    Location
    NJ, USA
    Posts
    104
    I downloaded powernowd and it works awesome. thnx for all the help.
    My New years Resolution is 1280x1024

  8. #7
    Just Joined!
    Join Date
    Nov 2004
    Location
    WGS84 phi = 45 48 31.7 lambda = 15 57 49.0
    Posts
    65
    well, anytime....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •