Find the answer to your Linux question:
Results 1 to 9 of 9
The message is ... Kernel Panic: VFS: Unable to mount root fs on hda3 I reckon this is because it might be trying to mount the partition using ext3, but ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User stokes's Avatar
    Join Date
    Oct 2004
    Location
    UK
    Posts
    274

    Kernel Panic after kernel upgrade to 2.6.5


    The message is ...

    Kernel Panic: VFS: Unable to mount root fs on hda3
    I reckon this is because it might be trying to mount the partition using ext3, but I chose reisers journaling file system (default on slackware install).

    Is my system rescuable? Is there any way to get some more detailed debugging information about the kernel panic?
    Registered Linux user #389109
    My Semi-Linux Blog

  2. #2
    Linux Enthusiast
    Join Date
    Aug 2005
    Posts
    542
    Show us your /etc/fstab. Since you can't access Linux on your hard drive, you should try burning a Damn Small Linux CD, booting to it, and viewing your fstab.
    Of course, I hope you didn't only have Linux on that computer...

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Location
    Kentucky
    Posts
    20
    Boot with the slackware install cd and pass the boot parameter:

    bare.i root=hda3

    The system will then boot to the command line. You said you did a kernel upgrade. I am thinking that means you compiled it yourself. If thats the case, you simply need to recompile and build in reiserfs support into the kernel. You either left it out or built it as a module.

    Go back to the build tree and start over. You do not have to do mrproper again or make clean. If you have done that, its not a problem, it will just take as long as it did for the first build.

    That's the good thing about the 2.6 kernels - just add what you need, recompile in seconds ( or minutes ).

    Delete the kernel that does not work, then install the new one. If you don't add any modules, /lib/modules/2.6.xx will be fine. If you do add modules, delete the relevant modules section before install.

    Piece of cake. It seems that compiling file system support is my biggest goof. Done it more than once.

  4. #4
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,628
    Before rebuilding your kernel, did you create the initrd? If not, read my post at the end of this thread...

    http://www.linuxforums.org/forum/topic-55562-90.html
    Linux Mint + IceWM Registered:#371367 New Members: click here

  5. #5
    Linux User stokes's Avatar
    Join Date
    Oct 2004
    Location
    UK
    Posts
    274
    Cheers for all the suggestions guys. This was my first time recompiling a kernel. To be honest I'm not sure whether I compiled it including reisersfs support ... there were so many options I could have missed it. I did it from within Gnome using 'make Gconfig'.

    Quote Originally Posted by Dapper Dan
    Before rebuilding your kernel, did you create the initrd?
    No I didn't, I'll try following your instructions first.


    Quote Originally Posted by chopin1810
    Show us your /etc/fstab. Since you can't access Linux on your hard drive, you should try burning a Damn Small Linux CD, booting to it, and viewing your fstab.
    Of course, I hope you didn't only have Linux on that computer...
    I do have Windows on another partition but that still works from LILO. I have a Mepis CD handy so will boot into it when I get home and ctrl+v my fstab here.
    Registered Linux user #389109
    My Semi-Linux Blog

  6. #6
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    As a side note, Slackware comes with a 2.6 kernel in the testing directory of the cd if you want an easy way to install a 2.6 kernel. Just cd to the directory with the kernel and installpkg *.tgz.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  7. #7
    Linux User stokes's Avatar
    Join Date
    Oct 2004
    Location
    UK
    Posts
    274
    Quote Originally Posted by bryansmith
    As a side note, Slackware comes with a 2.6 kernel in the testing directory of the cd if you want an easy way to install a 2.6 kernel. Just cd to the directory with the kernel and installpkg *.tgz.

    Bryan
    Cool thanks, I'll try that tonight. Is it as easy as installpkg *.tgz or do I have to do the initrd stuff afterwards?

    I reinstalled Slackware 10.1 with last night - it was quicker to do that than it was to troubleshoot the problem in the end! Getting into situations like this really reveals my newbie status. I seem to be fine with Linux until I get into situations where the system isn't bootable. Last night I did try the initrd thing but couldn't work out how to get the packages from Slackware's testing/packages/linux-2.6.13/ directory while I was booted from Slack CD1 using bare.i root=hda3.

    Luckily this is my Slack test box which I set up specifically to practice the Slackware 10.1 to 10.2 upgrade and Kernel upgrade/compile, I won't attempt to upgrade my Slackware QMail server until I can get this right!
    Registered Linux user #389109
    My Semi-Linux Blog

  8. #8
    Just Joined!
    Join Date
    Aug 2004
    Location
    Kentucky
    Posts
    20
    There is a README for initrd in the testing section. Read that, and you will know if you need it or not. Probably not.

  9. #9
    Linux User stokes's Avatar
    Join Date
    Oct 2004
    Location
    UK
    Posts
    274
    OK ... I'm a bit stumped again. I've installed the 2.6 kernel and can boot my system using it, but the Ndivia driver doesn't work as it was compiled for compatibility with the old kernel. When I try to install the driver using the Nvidia install package I get this message:

    ERROR: If you are using a Linux 2.4 kernel, please make sure
    you either have configured kernel sources matching your
    kernel or the correct set of kernel headers installed
    on your system.

    If you are using a Linux 2.6 kernel, please make sure
    you have configured kernel sources matching your kernel
    installed on your system. If you specified a separate
    output directory using either the "KBUILD_OUTPUT" or
    the "O" KBUILD parameter, make sure to specify this
    directory with the SYSOUT environment variable or with
    the equivalent nvidia-installer command line option.

    Depending on where and how the kernel sources (or the
    kernel headers) were installed, you may need to specify
    their location with the SYSSRC environment variable or
    the equivalent nvidia-installer command line option.
    The 2.6 kernel sources were installed when I did installpkg *.tgz. I figure that the Nvidia installer is trying to use the 2.4 kernel sources but am not sure how to configure this .. I have tried a few different command line options which didn't work. Do I need to delete a symlink to the 2.4 kernel sources somewhere and create a new one for the 2.6 kernel sources?

    If I make all these changes and get it working, does that mean I will no longer be able to boot using the old kernel? Not that I would want to .. I'm just interested.
    Registered Linux user #389109
    My Semi-Linux Blog

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •