Find the answer to your Linux question:
Results 1 to 5 of 5
Hey people. I'm a pretty new linux user. I made the switch about 2 months ago. I have 2 distros. Linspire 5.0 and Slackware 10.2. I have a pretty crappy ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2005
    Posts
    3

    Laptop Predicament


    Hey people. I'm a pretty new linux user. I made the switch about 2 months ago. I have 2 distros. Linspire 5.0 and Slackware 10.2. I have a pretty crappy laptop. its a stock (plus extra ram) HP. I'm in the process of trying to get 10.2 on my laptop but i've ran into some probs.

    1) I cant use the base kernal. It doesn't detect my keyboard if i do this
    2) I can use the test26.s kernal for the install but when it asks me for a root password during the install, yet again I cannot type at this point.
    3) I skip the root pw part and proceed. Installation finishes and I reboot. GRUB pops up after the BIOS crap and gives me error code 15 and occasionally er. code 17.

    It says with the slackware docs that GRUB is not included in the distro. I think GRUB has somehow been left over from linspire. I have used (c)fdisk til i'm blue in the face. I dont know how its still in my system. I am trying right now to partition my hdd and go ahead and install slackware and linspire in hopes the GRUB from linspire will enable me to launch slackware as well. If anybody can help me, i'll be your friend forever.

    Down with Bill Gates,
    Mek

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    The Hot Humid South
    Posts
    602
    Slackware is definately a jump from Linspire. The first thing I'm going to suggest is reading the SlackBook (available on the Slackware website).

    To answer your questions:
    1) What do you mean? How did you install the system if it didn't recognize the keyboard?
    2) You never actually see anything when you're typing the password, but it's there. It's just another security precaution. Type whatever you want the password to be and it'll be OK, most distros are like that. Just make sure you do it twice like it asks you to.
    3) I don't know how you ended up with GRUB, the Slackware default boot loader is LILO. Did you tell it to install LILO during the install? The only way LILO is not going to be install is if you choose to skip it, you don't want to do that because GRUB reads it's configuration file from a partition, which in your case is no longer there, which could explain your error.

    Again, grab a copy of the SlackBook and read it. Most of this stuff is covered there. After booting, you'll need to do A LOT of configuration, and the book will walk you through most of it.

  3. #3
    Just Joined!
    Join Date
    Oct 2005
    Posts
    3
    just about as soon as i posted that, i got it to work. your right about the invisible password. i'm just stupid. GRUB comes with linspire and for some reason it takes priority over LILO. ie. grub shows up first and displays my selections. I select slackware and then i'm taken to LILO to select slackware again lol. its not a big deal. both of em work. I ordered the "slackpack" from the website, the book was helpful upon initial installation. i also got a uber leet tshirt too just to help em out. if at all possible, i have an external hdd and it is connected to my laptop via a PCMCIA card which has a slot for an IEEE 1394. my external only has firewire connections and my laptop does not hence the reason for the card. anyway, i'd like to be able to access my external. i notice on linspire (which detects it), its labeled as sda1 under /mnt - any help in this area?

    thanks.
    mek

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    The Hot Humid South
    Posts
    602
    I've never messed around with FireWire, but if it's anything like USB, Linux will read it as a SCSI drive, that's why in Linspire it was had a sd* prefix. Slackware doesn't have automount, if you're interest in something like that, check this: Automount mini-Howto. If it is indeed in sda1, you'll mount it like this: "mount /dev/sda1 /mnt/hd". Where /dev/sda1 is the device (duh!), and /mnt/hd is the mount point. Slackware doesn't have a /mnt/sda1 mount point.

    Back to your GRUB and LILO thing, it looks like LILO didn't install itself on the MBR. Check this other how to: LILO.

  6. #5
    Just Joined!
    Join Date
    Oct 2005
    Location
    Ware Shoals, SC
    Posts
    14
    I agree with the previous post. Grub installed in the MBR. Then later when you installed Slackware, you installed in the superblock or something. I got around this by installing Lilo in the MBR. On my first attempt to install it, I was afraid to select this option on the install, because the installation program that came with Slackware 10.2 says this is unstable or something. But I put Lilo into the MBR and it works just fine. I am very new to this myself so I'm still tripping over the details.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •