Find the answer to your Linux question:
Page 3 of 4 FirstFirst 1 2 3 4 LastLast
Results 21 to 30 of 32
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Just Joined!
    Join Date
    Oct 2005
    Location
    Jacksonville, Florida, USA, Earth, Sol System, Milky Way galaxy...
    Posts
    18

    Okay, I went to the opening shell and typed
    Code:
    Touch /etc/lilo.conf
    mcedit /etc/lili.conf
    and made the change to the root = line and then did
    Code:
    lilo -v
    with the following results:
    Code:
    [omitting the copyright stuff at the top]
    
    Warning: LBA32 addressing assumed
    Reading boot sector from /dev/hda
    Fatal: creat /boot/map~: Read-only file system
    Did I leave a step out here somewhere?
    Lemme guess, I was supposed to type
    Code:
    chroot /mnt/hda1
    before this, right?

    Anyway, after I reboot, it gives me L 99 99 99 99 99 99 99... at startup, like usual...

  2. #22
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Yeah, you were supposed to chroot first.

  3. #23
    Just Joined!
    Join Date
    Oct 2005
    Location
    Jacksonville, Florida, USA, Earth, Sol System, Milky Way galaxy...
    Posts
    18
    Okay, I did
    Code:
    chroot /mnt/hda1
    touch /etc/lilo.conf
    mcedit /etc/lilo.conf
    to check that the settings were still what they were supposed to be, pressed 'F10' to exit, then did
    Code:
    lilo -v
    and got the result:
    Code:
    [...]
    
    Warning: LBA32 addressing assumed
    Reading boot sector from /dev/hda
    Warning: `/proc/partitions' does not exist, disk scan bypassed
    Warning: Unable to determine video adaptor in use in the present system.
    Calling map_insert_data
    Using bitmat file /boot/liloboot.bmp
    Calling map_insert_file
    
    Boot image: /boot/vmlinuz
    Added SLAMPP *
    
    Writing boot sector.
    /boot/boot.0300 exists - no boot sector backup copy made
    So, I rebooted, and got
    Code:
    L 99 99 99 99 99 99...
    Whimper...

  4. $spacer_open
    $spacer_close
  5. #24
    Just Joined!
    Join Date
    Oct 2005
    Location
    The Netherlands
    Posts
    2
    Well, it's a little bit strange why the PC still won't cooperate.

    As last approach, please try the following, you install SLAMPP manually. Just insert the SLAMPP Live CD into your CD-ROM drive and let it boot as usual until you get the login page. After that login with the approriate username and password.

    When you get the console, do the following:

    Code:
    cp --preserve -R /{bin,dev,etc,home,lib,root,sbin,usr,var} /mnt/hda1
    mkdir /mnt/hda1/{boot,mnt,proc,sys,tmp}
    cp /boot/boot/vmlinuz /mnt/hda1/boot 
    mount -t proc proc /mnt/hda1/proc
    mount --bind /dev /mnt/hda1/dev
    mount -t proc proc /mnt/hda1/proc
    chroot /mnt/hda1
    Replace 'hda1' with approriate partition. And then check the lilo.conf as stated in my previous posting.

    Code:
    boot = /dev/hda
    prompt
    timeout = 300
    vga=773
    
    image = /boot/vmlinuz
    root = /dev/hda1
    label = SLAMPP
    read-write
    If everything is OK, save it and do

    Code:
    lilo -v
    exit
    Now, reboot the computer

    Code:
    reboot
    and get the CD out of the CD-ROM drive.

    Let's see if SLAMPP could boot now.

  6. #25
    Just Joined!
    Join Date
    Oct 2005
    Location
    Jacksonville, Florida, USA, Earth, Sol System, Milky Way galaxy...
    Posts
    18
    Quote Originally Posted by kyantonius
    Well, it's a little bit strange why the PC still won't cooperate.

    As last approach, please try the following, you install SLAMPP manually. Just insert the SLAMPP Live CD into your CD-ROM drive and let it boot as usual until you get the login page. After that login with the approriate username and password.

    When you get the console, do the following:

    Code:
    cp --preserve -R /{bin,dev,etc,home,lib,root,sbin,usr,var} /mnt/hda1
    mkdir /mnt/hda1/{boot,mnt,proc,sys,tmp}
    At this point, I got the error:
    Code:
    mkdir: cannot create directory `/mnt/hda1/xyz': File exists
    repeated for each item in the curly-brackets. But then, I was doing this atop my existing install.
    Code:
    cp /boot/boot/vmlinuz /mnt/hda1/boot 
    mount -t proc proc /mnt/hda1/proc
    mount --bind /dev /mnt/hda1/dev
    mount -t proc proc /mnt/hda1/proc
    Here I got the error:
    Code:
    mount: according to mtab, proc is already mounted on /mnt/hda1/proc
    Was there a reason for the proc proc line to appear twice in your instructions?
    Code:
    chroot /mnt/hda1
    Replace 'hda1' with approriate partition. And then check the lilo.conf as stated in my previous posting.
    Did so. For some reason, it had
    Code:
    root = /dev/hda8
    which I promptly changed to
    Code:
    root = /dev/hda1
    and saved.

    Code:
    boot = /dev/hda
    prompt
    timeout = 300
    vga=773
    
    image = /boot/vmlinuz
    root = /dev/hda1
    label = SLAMPP
    read-write
    Incidentally, is the vga=773 part significant? I've got a different figure there. Should I change it to 773 such as you have here?
    If everything is OK, save it and do

    Code:
    lilo -v
    exit
    Now, reboot the computer

    Code:
    reboot
    and get the CD out of the CD-ROM drive.

    Let's see if SLAMPP could boot now.
    I still get
    Code:
    L 99 99 99 99 99 99 99...
    Is there any kind of diagnostics software I can try running on this? Something that tracks what the install does step by step? Or something that examines the installed settup as it exists now, and/or looks for something in this machine that might be tripping up the installer?

    I suppose I should probably give up and try installing this on another machine, but this one seems so perfect for it...

  7. #26
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    The Hot Humid South
    Posts
    606
    Try installing LILO to the MBR. You'll do that by changing the first "boot=/dev/hda1" to "boot=/dev/hda". That's assuming SLAMPP is installed in hda.

    Try adding "lba32" to the first line of that file. That seemed to have solved it for me (I had a similar issue).

  8. #27
    Just Joined!
    Join Date
    Oct 2005
    Location
    Jacksonville, Florida, USA, Earth, Sol System, Milky Way galaxy...
    Posts
    18
    Quote Originally Posted by bidi
    Try installing LILO to the MBR. You'll do that by changing the first "boot=/dev/hda1" to "boot=/dev/hda". That's assuming SLAMPP is installed in hda.

    Try adding "lba32" to the first line of that file. That seemed to have solved it for me (I had a similar issue).
    Okay, I assume you mean me to place lba32 as a line unto itself at the start of /etc/lilo.conf then. As for setting "boot = /dev/hda" there, it is already set to that. I have just noticed another oddity, though:

    I see "root = /dev/hda8" in /etc/lilo.conf, even though I know I changed that to "root = /dev/hda1" and saved it as such before invoking lilo -v at the prompt. I have no idea why it keeps switching itself back to "root = /dev/hda8" in the file afterwards.

    Maybe that's why the #$%@#$ machine keeps failing to install it.

    There must be something somewhere second-guessing me and saying, "No, he doesn't really mean to install root to /dev/hda1, he must really mean to install it to /dev/hda8, I'll just quietly switch this to /dev/hda8 and carry on with my business..."

    [Bangs head onto tabletop repeatedly]

  9. #28
    Check your BIOS dude. And see which disk is hooked up as primary.

    PS: The #lilo -A (should show the active partition ) then #lilo -M /dev/hdx(install MBR to active disk) should do the trick.

  10. #29
    Just Joined!
    Join Date
    Oct 2005
    Location
    Jacksonville, Florida, USA, Earth, Sol System, Milky Way galaxy...
    Posts
    18
    Quote Originally Posted by Dalani
    Check your BIOS dude. And see which disk is hooked up as primary.

    PS: The #lilo -A (should show the active partition ) then #lilo -M /dev/hdx(install MBR to active disk) should do the trick.
    Checked it. The one and only hard drive is hooked up as primary.

    #lilo -A /dev/hda yields
    Code:
    /dev/hda1
    #lilo -M /dev/hda yields
    Code:
    Fatal: creat /boot/boot.0300: Read-only file system
    Why would it be read-only? Where would I set it to not be read-only?

  11. #30
    sorry if I'm not helpful. But i had a similar sitiuation with my dual boot box. Sometimes we gotta check the obvious. Like you mentioned you hade put in this drive from another machine. I know you said it is primary but waht about the dip switch on the HD??? Is THAT set to master??

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •