Find the answer to your Linux question:
Page 1 of 4 1 2 3 4 LastLast
Results 1 to 10 of 32
I have a particular machine I have been trying to install various Linux distros onto, but once installed, they all crap out at the boot loader, whether it is Grub ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2005
    Location
    Jacksonville, Florida, USA, Earth, Sol System, Milky Way galaxy...
    Posts
    18

    New install of SLAMPP (Slackware/Slax distro) gives me L 99 99 99 99 99...


    I have a particular machine I have been trying to install various Linux distros onto, but once installed, they all crap out at the boot loader, whether it is Grub or Lilo being used.

    I am now trying out SLAMPP (http://slampp.abangadek.com/wiki/wik...wakka=HomePage), and at bootup all I get is
    Code:
    L 99 99 99 99 99 99 99 99 ...
    Following another thread, here:

    http://www.linuxforums.org/forum/topic-41149.html

    ...I am instructed to invoke fdisk -l and post the output, and to post the contents of lilo.conf with it.

    Here is the fdisk -l output:
    Code:
     Disk /dev/hda: 10.2 GB, 10254827520 bytes
    255 heads, 63 sectors/track, 1246 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    
    Device     Boot Start  End    Blocks      Id  System
    /dev/hda1  *         1  1200  9638984+ 83  Linux
    /dev/hda2        1201  1246  369495      5  Extended
    /dev/hda5        1201  1246  369463+   82 Linux swap
    On the other hand, I cannot find lilo.conf on this machine. I have looked in /etc/ and I have looked in other places, but there doesn't seem to be an /etc/lili.conf file on my machine!

    Maybe that's why it's getting stuck at
    Code:
    L 99 99 99 99 99...
    I have used the built-in install-to-hard-drive routine on the above live-CD, so it's nothing I've done wrong.

    The CD itself boots perfectly fine onto this machine, I just can't boot from the hard drive...

    BTW, I have successfully installed Windows onto this machine (an eval version of Windows Server 2003 Enterprise Edition snail-mailed to me by Microsoft) and have since wiped it. Windows worked perfectly on it, so that rules out this being a "bad machine." The machine just doesn't like Linux...

    -- addendum:

    Oops! Forgot to mention the specs of the machine:
    Micron Millenia
    Celeron
    256 megs of RAM
    10 gig hard drive.

    BTW, the original hard drive that came with it was broken. Somebody had snapped the molex connector clean off the drive! I am using another drive that I pulled out of another machine when I upped that machine to a bigger drive.

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    You can see if you even have a lilo.conf in some non-standard location by chroot'ing in from the LiveCD and issuing, as root:
    Code:
    find / -iname lilo -type f 2>/dev/null

  3. #3
    Just Joined!
    Join Date
    Oct 2005
    Location
    Jacksonville, Florida, USA, Earth, Sol System, Milky Way galaxy...
    Posts
    18
    I type find / -iname lilo -type f z>/dev/null and get:
    Code:
    find: paths must precede expression
    usage: find [path...] [expresssion]
    ---addendum:
    Left out the z>/dev/null from the expression, and got:
    Code:
    /mnt/live/memory/images/sbin.mo/sbin/lilo
    /mnt/hda1/sbin/lilo
    /sbin/lilo

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    1. That was the number 2 not the letter z
    2. It seems that you have no lilo.conf anywhere.

    So:
    Code:
    chroot /mnt/hda1
    $EDITOR /etc/lilo.conf
    and create an acceptable lilo.conf file, then run:
    Code:
    /sbin/lilo
    When you're done, press Control-D, and reboot.

  6. #5
    Just Joined!
    Join Date
    Oct 2005
    Location
    Jacksonville, Florida, USA, Earth, Sol System, Milky Way galaxy...
    Posts
    18
    Quote Originally Posted by lakerdonald
    1. That was the number 2 not the letter z
    Whoops!
    2. It seems that you have no lilo.conf anywhere.

    So:
    Code:
    chroot /mnt/hda1
    $EDITOR /etc/lilo.conf
    At this point in the process I got
    Code:
     bash: /etc/lilo.conf: Permission denied
    ...so couldn't take it any further.
    and create an acceptable lilo.conf file, then run:
    Code:
    /sbin/lilo
    When you're done, press Control-D, and reboot.

  7. #6
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Uh, I guess $EDITOR is undefined...Try "nano" instead:
    Code:
    nano /etc/lilo.conf

  8. #7
    Just Joined!
    Join Date
    Oct 2005
    Location
    Jacksonville, Florida, USA, Earth, Sol System, Milky Way galaxy...
    Posts
    18
    Okay, well... doing
    Code:
    chroot /mnt/hda1
    nano /etc/lilo.conf
    results in
    Code:
    bash: nano: command not found
    but if I type it as
    Code:
    $nano /etc/lilo.conf
    I get the same
    Code:
    bash: /etc/lilo.conf permission denied
    as before.

    BTW, I am logged on as root while doing this.

  9. #8
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Try
    Code:
    vim /etc/lilo.conf
    or
    Code:
    emacs /etc/lilo.conf

  10. #9
    Just Joined!
    Join Date
    Oct 2005
    Location
    Jacksonville, Florida, USA, Earth, Sol System, Milky Way galaxy...
    Posts
    18
    Neither vim or emacs apear to be on this machine. It does have BlueFish, TEA, and NVU on it, though.

    NVU appears to be an HTML editor.

    Anyway, I did
    Code:
    chroot /mnt/hda1
    TEA /etc/lilo.conf
    and this is what came up in /etc/lilo.conf:
    Code:
    boot = /dev/hda
    timeout = 0
    vga=791
    
    bitmap=/boot/liloboot.bmp
    bmp-colors=1,,8,3,8,1
    bmp-table=60p,110p,1,18
    bmp-timer=95p,400p,3,8,1
    
    image = /boot/vmlinuz
       root = /dev/hda1
       label = SLAMPP
       read-write
    I think this was created from the admin web interface at port 10000, via the Hardware tab, where it lets me set the boot parameters. I had figured maybe setting things there would make it boot properly. However, at boot, I still get
    Code:
    L 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 99 ...
    I have not editted /etc/lilo.conf using TEA, though. I just looked at the file contents, quit out of TEA and rebooted...

  11. #10
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    You need to re-run lilo manually from the chroot, remember?
    Code:
    /sbin/lilo

Page 1 of 4 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •