Find the answer to your Linux question:
Page 3 of 5 FirstFirst 1 2 3 4 5 LastLast
Results 21 to 30 of 45
Originally Posted by djap Code: artsdsp mozilla-firefox That gets sound! Thing is, the sound doesn't sync with the action. It's off by a second or two late. Wonder why that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,628

    Quote Originally Posted by djap
    Code:
     artsdsp mozilla-firefox
    That gets sound! Thing is, the sound doesn't sync with the action. It's off by a second or two late. Wonder why that is? Anyway, it's progress so thanks djap!
    Linux Mint + IceWM Registered:#371367 New Members: click here

  2. #22
    Linux Guru
    Join Date
    Nov 2004
    Posts
    6,110
    No joy for me. Says it needs to be a binary, and my mozilla-firefox is a shell script for setting environment variables and then launching.

  3. #23
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Hmmm ... I tried artsdsp mozilla-firefox and it's actually made things much worse! I learnt a harsh lesson last night... If it's not particularly bust, don't fix it.
    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  4. #24
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,628
    I ran it as:
    Code:
    artsdsp firefox
    and the sound works, but still is out of sync. Surely there is a configuration file somewhere that tells Firefox to use arts and if it's not available, go to oss. I wish I could find this...
    Linux Mint + IceWM Registered:#371367 New Members: click here

  5. #25
    Linux Guru fingal's Avatar
    Join Date
    Jul 2003
    Location
    Birmingham - UK
    Posts
    1,539
    Quote Originally Posted by Dapper Dan
    I ran it as:
    Code:
    artsdsp firefox
    and the sound works, but still is out of sync. Surely there is a configuration file somewhere that tells Firefox to use arts and if it's not available, go to oss. I wish I could find this...
    This might help.

    edit /etc/mozilla-firefox/mozilla-firefoxrc and change

    FIREFOX_DSP="auto"

    or

    FIREFOX_DSP="none"

    to

    FIREFOX_DSP="arts"

    I am always doing that which I can not do, in order that I may learn how to do it. - Pablo Picasso

  6. #26
    Just Joined!
    Join Date
    Nov 2005
    Posts
    1
    If none of the above suggestions work, give this a try:

    1) open the KDE control center (kcontrol)

    2) select sound->sound system

    3) make sure "Enable the sound system" is checked

    4) click the hardware tab, and under the "Select audio device" popup menu, select "Enlightened Sound Daemon"

    I haven't tried using artsdsp, so I don't know what kind of lag you're experiencing, but firefox's sound output with this method doesn't seem lagged to me (it's possible that there's a short (<1 sec) lag).

  7. #27
    Linux User Krendoshazin's Avatar
    Join Date
    Feb 2005
    Location
    London, England
    Posts
    471
    I had the same problem, I use firefox and fluxbox, I simply added myself to the audio group in /etc/group and it was sorted

  8. #28
    Just Joined!
    Join Date
    Nov 2005
    Posts
    1
    I had the same problem under Suse 10, but after I installed the flash-player in YAST it was working!

    Cheers

  9. #29
    Just Joined!
    Join Date
    Dec 2005
    Posts
    1
    In my case it was a permission thing. Logging in as root, sound worked, logging in as user didn't. I followed the adding myself to the audio group and that didn't do it either. But, adding myself to the video group did the trick. You wouldn't think that would work with getting video but no sound, but it did in my case.

  10. #30
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    Quote Originally Posted by slackuser67
    In my case it was a permission thing. Logging in as root, sound worked, logging in as user didn't. I followed the adding myself to the audio group and that didn't do it either. But, adding myself to the video group did the trick. You wouldn't think that would work with getting video but no sound, but it did in my case.
    doubt it

    did you login between adding yourself to audio and video?

    sounds like it

    krendo: I did the same as you..

Page 3 of 5 FirstFirst 1 2 3 4 5 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •