Find the answer to your Linux question:
Page 4 of 5 FirstFirst 1 2 3 4 5 LastLast
Results 31 to 40 of 45
I've had this problem for a while now and I believe I just found the answer. Go into the Control Center in KDE and under Sound System unselect Enable Sound ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #31
    Just Joined!
    Join Date
    Dec 2005
    Posts
    1

    I've had this problem for a while now and I believe I just found the answer.

    Go into the Control Center in KDE and under Sound System unselect Enable Sound System.

    I noticed if I killed all artsd instances running and opened firefox again flash played just fine. I'm assuming Arts and Alsa are fighting over the device.

    Once I deselected Enable Sound System I had no more problems.

  2. #32
    Just Joined!
    Join Date
    Jan 2006
    Location
    Camden, NJ
    Posts
    1
    This worked for me.

    modprobe snd-pcm-oss

    Many programs (including Mozilla) will look for /dev/dsp, which was not present in my machine. Modprobing snd-pcm-oss fixed the problem.

  3. #33
    Just Joined!
    Join Date
    Feb 2006
    Posts
    4
    Quote Originally Posted by dmadcat
    I've had this problem for a while now and I believe I just found the answer.

    Go into the Control Center in KDE and under Sound System unselect Enable Sound System.

    I noticed if I killed all artsd instances running and opened firefox again flash played just fine. I'm assuming Arts and Alsa are fighting over the device.

    Once I deselected Enable Sound System I had no more problems.
    This worked perfectly for me, however I have one more problem, im on a laptop and my volume is always really loud, it doesnt change when i use the volume scroll thing on the side of the lappy, any ideas would be appreciated

  4. #34
    Just Joined!
    Join Date
    May 2006
    Posts
    1
    Quote Originally Posted by gerardo76
    This worked for me.

    modprobe snd-pcm-oss

    Many programs (including Mozilla) will look for /dev/dsp, which was not present in my machine. Modprobing snd-pcm-oss fixed the problem.

    this actually worked perfect for me. once i did it and closed/reopened my browsers sound worked immediately in flash.


    using-- debian-unstable kernel 2.6.16-2 kde3.5 with opera,firefox, and konqueror

  5. #35
    Just Joined!
    Join Date
    May 2006
    Posts
    1

    but shouldn't KDE idle and release?

    I've had this problem for a while now and I believe I just found the answer.

    Go into the Control Center in KDE and under Sound System unselect Enable Sound System.

    I noticed if I killed all artsd instances running and opened firefox again flash played just fine. I'm assuming Arts and Alsa are fighting over the device.

    Once I deselected Enable Sound System I had no more problems.
    Yes, this is the only thing that worked for me too. But, that same Control Panel window also says:
    The KDE sound system takes exclusive control over your audio hardware, blocking programs that may wish to
    use it directly. If the KDE sound system sits idle it can give up this exclusive control.
    Choosing "Auto-suspend if idle after:" (the default, I think) doesn't seem to help. Does it not release? Is this what is blocking Flash?

  6. #36
    Just Joined!
    Join Date
    Jun 2006
    Posts
    1

    Re: Firefox+flash+kde audio problem

    Kde had this problem for sometime ... it opens up artsd and blocks audio. You can kill artsd process (by issueing the commands:
    $ ps -aef |grep artsd
    $ kill -9 <process no.>
    )

    For me, I needed to kill artsd process only once and later the sound worked ... it may require killing at every log-in for others ... I don't know ...(shrug).

    Have fun.

  7. #37
    Just Joined!
    Join Date
    Jun 2006
    Posts
    1
    Check if alsa-oss is installed, then

    $ sudo gedit /etc/firefox/firefoxrc

    FIREFOX_DSP=”aoss”


    That should work,
    Cheers,

    ruipb
    Debian User

  8. #38
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    There is no /etc/firefox on slackware.

  9. #39
    Just Joined!
    Join Date
    Oct 2006
    Posts
    3
    Firefox + Flash = no sound

    Hi everyone, I'm completely new to Linux (SUSE 10.0) and I wouldn't dare call myself a begginer in programming, so I will ask you to be patient on me. This firefox/flash problem is driving me nuts, apparently is not an easy one to be dealt with since I've seen a couple of posts by "graduated" linux users to whom this SHITuation is of apparent non-resolvability.

    I've tried some of the suggestions posted, none of them work, however there are some I couldn't (due to my handicap on programming) put to practice as of yet:

    Quote Originally Posted by ruipb
    $ sudo gedit /etc/firefox/firefoxrc

    FIREFOX_DSP=”aoss”
    No such folder!!! Perhaps because I run firefox out of a shell application (1.5.0.7)

    Quote Originally Posted by Krendoshazin
    I had the same problem, I use firefox and fluxbox, I simply added myself to the audio group in /etc/group and it was sorted
    In lame terms what does this mean? Adding a folder called to /etc named group and then another one with our username?

    Originally Posted by gerardo76
    This worked for me.

    modprobe snd-pcm-oss

    Many programs (including Mozilla) will look for /dev/dsp, which was not present in my machine. Modprobing snd-pcm-oss fixed the problem.
    Don't know how to do it. On the terminal window... (line of command)?

    Anyway, if you could give me a handout on this one it'll be appreciated.

    Thanks in advance

  10. #40
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

Page 4 of 5 FirstFirst 1 2 3 4 5 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •