Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
Just recently installed Vector Linux 5.1, which I am led to believe is a Slackware derivative. Hopefully then, this is the right forum to post in. When trying to mount ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Location
    Washington
    Posts
    70

    [SOLVED] Vector Linux Cdrom Problems


    Just recently installed Vector Linux 5.1, which I am led to believe is a Slackware derivative. Hopefully then, this is the right forum to post in.

    When trying to mount a CD in my CdRom drive, I get an error :

    mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so
    Mount failed

    syslog -try doesn't seem to be a valid command. So what exactly the error was, i'm uncertain.

    Has anyone else dealt with a similiar problem? If so, any help would be much appreciated. Thank You

    waltaja

  2. #2
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Are you mounting it from a GUI or the command-line?
    Registered Linux user #270181
    TechieMoe's Tech Rants

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Location
    Washington
    Posts
    70
    from the gui under IceWm-ROX

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Quote Originally Posted by waltaja
    from the gui under IceWm-ROX
    Do you have multiple icons for your drive? Mine had CDROM, CDRW, DVD, etc. Have you tried mounting using one of the other icons?
    Registered Linux user #270181
    TechieMoe's Tech Rants

  6. #5
    Just Joined!
    Join Date
    Aug 2005
    Location
    Washington
    Posts
    70
    id have the options of CD CDWriter and DVD. I do have a CDWriter and a "regular" CD drive, but no DVD. I have tried mounting under all of the options and each was to no avil. I also tried running VASM again, and that also didn't work.

    I appreciate your help. Thanks

  7. #6
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Are you able to mount it as root from the command line?
    Registered Linux user #270181
    TechieMoe's Tech Rants

  8. #7
    Just Joined!
    Join Date
    Aug 2005
    Location
    Washington
    Posts
    70
    i just tried. the message i get is : can't find cdrom in /etc/fstab or /etc/mtab

    same happens if i try to mount hdc or hdd

  9. #8
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Quote Originally Posted by waltaja
    i just tried. the message i get is : can't find cdrom in /etc/fstab or /etc/mtab

    same happens if i try to mount hdc or hdd
    Can you post the contents of your /etc/fstab file and what the exact mount command is you're using?
    Registered Linux user #270181
    TechieMoe's Tech Rants

  10. #9
    Just Joined!
    Join Date
    Aug 2005
    Location
    Washington
    Posts
    70
    #CDROM, CDWRITER, DVD
    /dev/cdrom /mnt/cdrom iso 9660 noauto,user,ro 0 0
    /dev/cdwriter /mnt/cdwriter iso 9669 noauto,user,rw, 0 0
    /dev/dvd /mnt/dvd iso moauto iso 9660 noauto,user,ro 0 0

    that's the CD portion of the fstab file

    the command is : mount /dev/cdrom

    and i've tried mount /dev/hdc and mount /dev/hdd

  11. #10
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    This may or may not help, but you could try changing the "iso 9660" line to "auto", like this:

    Code:
    /dev/cdrom /mnt/cdrom auto noauto,user,ro 0 0
    Registered Linux user #270181
    TechieMoe's Tech Rants

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •