Find the answer to your Linux question:
Results 1 to 5 of 5
I'm having a few issues shutting down slackware. Whenever I use the shutdown command in console or shutdown from the gnome menu, it begins the process but does not power ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2005
    Location
    Melbourne, Australia
    Posts
    6

    Shutdown troubles


    I'm having a few issues shutting down slackware.

    Whenever I use the shutdown command in console or shutdown from the gnome menu, it begins the process but does not power down, which forces me to manually reset and hit power.

    However, when I reset it says that the hardrive was not cleanly unmounted, and requires a disk check.

    I was wondering if anyone had any advice?

    Thanks

  2. #2
    Banned
    Join Date
    Jul 2004
    Posts
    947
    as root
    Code:
    init 0
    does it shutdown correctly for that?

    and did you try the -h flag with shutdown?

  3. #3
    Just Joined!
    Join Date
    Nov 2005
    Location
    Melbourne, Australia
    Posts
    6
    Thanks for the help so far,
    After typing "init 0" it runs through the shutdown phase, and then says "Power down" - at this point it stops.

    Nothing seems to happen after this point.

  4. #4
    Linux User Game master pro's Avatar
    Join Date
    Sep 2005
    Location
    Tasmania, australia
    Posts
    274
    34) When I shutdown my computer using halt or shutdown -h it does not turn off automatically. How do I change that?

    Most newer machines can power off automatically when you shut them down. This is typically accomplished through APM (Advanced Power Management). By default Slackware does not load the apm kernel module, and this prevents the machine from shutting down through APM. To enable the apm kernel module you simply have to edit the file /etc/rc.d/rc.modules and make sure the /sbin/modprobe apm line is uncommented (by default the line is commented out by being prefixed with a '#' - remove the # and save the file). If you enable the apm module in this way then the next time you reboot your machine should be able to power down when you issue the halt or shutdown -h now or similar commands (or shut down through your GUI).

    I think this is your problem

  5. #5
    Just Joined!
    Join Date
    Nov 2005
    Location
    Melbourne, Australia
    Posts
    6
    Thanks very much for that, after enabling the module shutdowns run perfectly

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •