Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
I have i810 video on board from intel, and an eizo F56 monitor. I'm really new on slackware, and when i start X, only resolution i have is verry low... ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie mindblast's Avatar
    Join Date
    Nov 2005
    Location
    iasi, RO
    Posts
    132

    slackware 10.2 video drivers


    I have i810 video on board from intel, and an eizo F56 monitor. I'm really new on slackware, and when i start X, only resolution i have is verry low... where do i find drivers for my board or my monitor, and how do i install them?

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    what do you need drivers for ?

    setup X properly

    if you're new to slackware the best thing you can do is give the slackbook a read


    www.slackbook.org

  3. #3
    Linux Newbie mindblast's Avatar
    Join Date
    Nov 2005
    Location
    iasi, RO
    Posts
    132
    I've run xorgconfig, and kde wasn't start at all... so i've installed again slackware, but now i don't wanna run xorgconfig again... In Red Hat i know i had Xconfigurator... Slackware dosen't have somenthing like that, i mean something more easy to use? sorry i's such a newbie...

  4. #4
    Just Joined!
    Join Date
    Oct 2004
    Posts
    34
    Chances are you aren't setting up your monitor correctly. If you have a manual, find the vertical and horizontal refresh rates, and set the resolutions allowed in your xorg.conf file (if you use xorgconfig, it will automatically save settings to your xorg.conf file, though you still have to set them manually).

    If you don't have a manual for your monitor, find the model number and manufacturer (should be on your monitor somewhere) and look for an online specifications manual.

    You will not be able to use a higher resolution or higher color settings without correctly setting up your xorg.conf file to reflect the settings of your monitor...your graphics card really has nothing to do with it.

    EDIT: If you do want to manually set up your xorg.conf file instead of using xorgconfig, you will have to load it up into a text editor and change the correct areas. I'm not an expert when it comes to this, but I can find my way around the xorg.conf file when it's in front of me. However, I don't currently have a distro installed, so I can't tell you exactly what to edit, but it should be somewhere below graphics settings, and should have either "screen" or "monitor" in the title of the section.

    If you're stuck in the command line, use the command
    Code:
    vim /etc/X11/xorg.conf
    to load up your xorg.conf file, and edit appropriately. Be advised that vim is not the easiest text editing program to use, and would be much easier in a graphical environment.

    If you're only seeing the command line, and not getting any default window manager, try using the command
    Code:
    init 4
    in the command line after you log on to root from the command line. It *should* load up a graphical user interface for you to log on with, and you can use kedit instead of vim to edit your xorg.conf file.

  5. #5
    Linux Newbie mindblast's Avatar
    Join Date
    Nov 2005
    Location
    iasi, RO
    Posts
    132
    i've done that, i set up mannualy my monitor and graphical card... I foud the corect refresh rates for monitor, and if i select my graphical card to run on 16 or 24 bits, when i try to start x, give me an error that say "Given depth (16) is not supported by this driver" and "screen(s) found, but none have a usable configuration" "fatal error: no screens found". If i set up my board to run at 256 collors, startx running bun on a 320X200 resolution or something like that, and i can't do nothing...

  6. #6
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    what X driver is it using?

    have you changed it ? it sounds like its still on VGA

  7. #7
    Linux Newbie mindblast's Avatar
    Join Date
    Nov 2005
    Location
    iasi, RO
    Posts
    132
    Yes. Vga is writing in xorg.conf. But i don't change a thing. Today i've install slackware for my first time.

  8. #8
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    read the slackbook and learn how to configure X

    I often wonder how people end up with slackware when they can't get X working.

    I really recommend another distro to you like ubuntu

    www.slackbook.org

  9. #9
    Linux Newbie mindblast's Avatar
    Join Date
    Nov 2005
    Location
    iasi, RO
    Posts
    132
    i've read slackbook and i've did everything the book said... Butt still don't working. I've tried other operating systems and i want slackware. 10x for all your help.

  10. #10
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    post the contents of your xorg.conf and dmesg / lsmod please.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •