Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 21
Can you see your wireless connection in ifconfig -a or iwconfig?? try: ifconfig wlan0 up iwconfig wlan0 essid <routername> key <routerkey> open dhcpcd wlan0...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Dec 2005
    Posts
    1

    Can you see your wireless connection in ifconfig -a or iwconfig??

    try:

    ifconfig wlan0 up
    iwconfig wlan0 essid <routername> key <routerkey> open
    dhcpcd wlan0

  2. #12
    Just Joined!
    Join Date
    Jan 2003
    Posts
    26
    Well, firstly, have you compiled it yet?

    I checked out the readme for the rt2500 model, and it seems pretty straightforward, but if it didn't work I can try to help you there. (I'll have to know what kernel you're using)

    But, if you have the driver built for your kernel already, I wouldn't follow their insertion instructions... I would just use $modprobe rt2500 (rather than insmod) because modprobe will make sure all the dependant modules are also loaded.

    After that, type:
    $iwconfig

    If you see a device titled rt0 (according to their documentation, that's what it should be called) then you are in good shape. Type:

    $iwconfig rt0 essid [the name of your WAP, not in brackets]

    If you have WEP enabled, you'll need to use that option to set your wep key as well.

    Then:

    $dhcpcd rt0

    That will get you an IP address from the WLAN router. I saw somebody suggested setting it with ifconfig, but I think that would only work if you were using an ad-hoc network. The dhcpcd will take a few moments, but once it's done, you should be able to run ifconfig to see that you have an IP address for the adaptor. If so, you should be good to go!

  3. #13
    Linux Newbie
    Join Date
    Apr 2005
    Location
    CT --> PA
    Posts
    170
    agreed, good instructions...but...is your WAP using WPA??? That will change things a little.
    Chicks dig giant mechanized war machines

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Apr 2005
    Location
    Upper Peninsula of Michigan
    Posts
    57
    Did you grab an ip address from the dhcp server? you can check with ifconfig -a, if not you may need to run the command dhcpcd wlan0 or whatever your device is named

  6. #15
    Just Joined!
    Join Date
    Dec 2005
    Posts
    20
    Quote Originally Posted by THEcheesedog
    It was able to see my network and connect. However, I was still unable to pull any web pages.
    Well, I've seen this before in my own experience but anywho, have you made sure that your DNS server has been identified? Since you can connect to the network, I would run 'netconfig' to configure it. If that doesn't help, check out the file /etc/resolv.conf and if it doesn't have a line saying "nameserver 0.0.0.0" (no quotes, put in your nameserver's ip) then try adding it.

    Also, check out the results of 'route'. If dhcp was successful on your wireless card then it should have put routing information in there. If not, then you may have to manually set it up. (e.g. route add default gw 192.168.0.1 dev wlan0).

    If the gateway is another computer in the network, and the /etc/resolv.conf file is configured, then typing 'route' could show the computer name of your gateway. To check the internet connectivity, do something like 'links www.google.com'

    good luck
    --Luke

  7. #16
    Just Joined!
    Join Date
    Dec 2005
    Location
    Kansas
    Posts
    8
    All apologies for the long hiatus didn't pay the interweb bill heh but besides that I got the interweb back. On to the status. Well I got the driver compiled and working. However, the only way I could get it to work is that I have to manually load the module everytime and use their GUI interface to load the wireless network and then use dhcpcd to grab an ip address from the router. So, I still need to find a way to load the driver into the kenels configuration and make it load automatically at startup.......any help greatly appreciated.

  8. #17
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Hi THEcheesedog,

    I just went throught this process with the Ralink drivers on the Linksys WMP54g v4. I posted about it here. What I did was set all the commands up in /etc/rc.d/rc.local...
    Code:
    /sbin/ifconfig ra0 up
    dhcpcd ra0
    /sbin/iwconfig ra0 essid "your_essid"
    /sbin/iwconfig ra0 enc YOUR-WEP-KEY-HERE-ETC-ETC
    /sbin/iwconfig 'commit' won't work for me so that's why the bottom two are there. When you say the driver will not load, look in /etc/modules.conf. I added this to mine:
    Code:
    # To load the ralink wireless driver...
    alias ra0 rt2500
    I don't know if this is the right way it should be done but it works for me every time I boot. Hope this helps...
    Last edited by Dapper Dan; 04-04-2006 at 05:32 AM.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  9. #18
    Just Joined!
    Join Date
    Dec 2005
    Location
    Kansas
    Posts
    8
    Thank you DapperDan, I'll give this a try when I get home. Will there be any differences when setting up the encryption key, as I do not use WEP.....I'm use WPA?

  10. #19
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Haven't gotten into WPA... yet... I have read where some folks have had problems getting WPA to work, but those posts were relatively old. The Ralink open source folks are really on the ball! Many of the steps that used to have to be done 'by hand' are now bulit into the tarball. For instance, you no longer have to edit /etc/modules.config to include 'alias ra0 rt2500,' the CVS version now does that for you. By the way, I think I got the order of the commands to put in /etc/rc.d/rc.local a little out of kilter. Works better this way...
    Code:
    /sbin/iwconfig ra0 essid "your_essid"
    /sbin/iwconfig ra0 enc YOUR-WEP-KEY-HERE-ETC-ETC
    /sbin/ifconfig ra0 up
    dhcpcd ra0
    That is if you were to use WEP and /sbin/iwconfig won't 'commit' like it won't for me. Hadn't figured that one out yet...

    I've jumped head over heals onto the Ralink bandwagon! I bought the Linksys WUSB54G Wireless adapter yesterday. It was a version 4.3 which had me worried since the known version with the Ralink chipset is version 4. I wish Linksys would put the version number on the outside of the box! When I plugged it in and did /sbin/lsusb, something showed up but there was nothing listing it was a Linksys. I decided to download and install the rt2570 drivers and compile them anyway, and low and behold it worked! I now have two boxes in wireless 'G' using the Ralink chipset and am extremely happy with the wireless performance of both.


    (As long as I've been here, I think this is my first use of the dancing banana, so you know I'm very pleased!)
    Linux Mint + IceWM Registered: #371367 New Members: click here

  11. #20
    Just Joined!
    Join Date
    May 2006
    Posts
    2

    Talking

    Cool Thread!!
    Just signed up to congrats you guys for the thread !!
    Saved me from a lot of googleing!!

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •