Find the answer to your Linux question:
Results 1 to 4 of 4
I run slackware 10.1, I recently followed the instructions to upgrade to the kernel 2.6.10 provided in the /testing directory, and I created the initrd and installed the kernel-generic, kernel-modules, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Posts
    13

    ALSA problems after upgrading to 2.6.10


    I run slackware 10.1, I recently followed the instructions to upgrade to the kernel 2.6.10 provided in the /testing directory, and I created the initrd and installed the kernel-generic, kernel-modules, kernel-headers and alsa-driver package in the /testing directory of the 2nd cd.

    The new kernel boots fine, but the problem I am facing is that after running alsaconf, my sound card (a Yamaha ISA sound card with module snd-opl3sa2) is detected, but on rebooting and running any sound application (like mpg321), I get -

    Code:
    ALSA lib confmisc.c:550:(snd_determine_driver) could not open control for card 0
    ALSA lib conf.c:3463:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
    ALSA lib confmisc.c:387:(snd_func_concat) error evaluating strings
    ALSA lib conf.c:3463:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
    ALSA lib confmisc.c:945:(snd_func_refer) error evaluating name
    ALSA lib conf.c:3463:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
    ALSA lib conf.c:3932:(snd_config_expand) Evaluate error: No such file or directory
    ALSA lib pcm.c:2068:(snd_pcm_open_noupdate) Unknown PCM default
    No default libao driver available.
    Even manually modprobing the driver gives the same result, and I have no idea how to go about fixing this. Any help would be much appreciated.

    Thanks in advance

  2. #2
    Linux User St. Joe's Avatar
    Join Date
    Jun 2005
    Location
    USA
    Posts
    271
    It might be worth using alsamixer to get the proper mix on your audio settings, and then save those before your next reboot.

    $ alsamixer
    # alsactl store
    It may be that your sole purpose in life is simply to serve as a warning to others.

  3. #3
    Just Joined!
    Join Date
    Dec 2005
    Posts
    13
    Thanks for your help, well the problem is that the error was encountered while loading the modules itself, so I do not think setting the volume correctly would help.

    But the good news is that I removed the configuration setup by alsaconf, and instead enabled hotplug at bootup, and now I have my sound card working fine. However, I would prefer to have a working sound card without having to run hotplug each time, so is there any way I could find the settings used by my sound card driver, and configure it manually?

  4. #4
    Just Joined!
    Join Date
    Dec 2005
    Posts
    13
    Allright, I finally could get it to work by removing the options line added by alsaconf to /etc/modprobe.conf, I wonder why it detected the settings incorrectly?

    Thanks for your help btw, when I could finally load my sound card module (snd-opl3sa2) properly, I was still not getting any sound and it turned out that the volume levels had been muted

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •