Find the answer to your Linux question:
Results 1 to 2 of 2
I am trying to set up a Slackware 10.2 install to function as the household IMAP server. I have my own registered domain name, and have it being hosted at ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2005
    Location
    Jacksonville, Florida, USA, Earth, Sol System, Milky Way galaxy...
    Posts
    18

    Question How to change from xyz.blah.com to blah.com in mail headers


    I am trying to set up a Slackware 10.2 install to function as the household IMAP server. I have my own registered domain name, and have it being hosted at a webspace provider (webpage and webforum). I want the local server, however, to place the same domain name in the From: line of all mails from the local, household server.

    For the sake of discussion, let's call the registered domain Blah.com. I set up the local server with the name Server, and that is the name I can ping it from the Windows machines as (thanks to Samba).

    However, when I post test messags to myself, from shell on the Slackware machine, they show up with nomad@server.blah.com in the From: line. I want all messages to instead say nomad@blah.com in the headers.

    I have tried editting /etc/HOSTNAME and /etc/hosts to eliminate server. from the name, but that causes other problems, including, at startup: httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName as well as, at other points, complaining about not being able to do reverse lookup, or something of the sort, on my domain name, and so couldn't launch httpd (or some other service like that), and then the shell prompt coming up with the domain name different than it should.

    I.e., originally it was coming up nomad@server:~$, but after various tinkering with the above, it came up nomad@blah.com and even nomad@blah

    But at least at one point my From: line came up the way I wanted it...

    I then restored /etc/HOSTNAME back to the longer server.blah.com and the problems went away, but I'm back to the domain name appearing "wrong" in my mail headers.

    Is there a simple, system-friendly way to have sendmail always have mailheaders say From: nomad@blah.com in the headers? Without me having to fly through hoops to do it?

  2. #2
    Just Joined!
    Join Date
    Oct 2005
    Location
    North Carolina, USA
    Posts
    45
    I'm not a sendmail expert, but I set this up somehow on my Slackware 10.0 box a while back.. I just can't remember exactly how!

    I checked /etc/mail and found that I listed the following in the local-host-names file there:

    blah.com
    server.blah.com

    Beyond that, I think I just specify me@blah.com in my email clients as the email address. (In Thunderbird, for example, I see me@blah.com throughout my account settings.)

    Hope this helps!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •