First off, here is my network:

The problem is this: I cannot connect to bldg 1 from the laptop (I can ping bldg 1 if I specify wlan0 interface, but cannot access the webservers in bldg 1) if eth0 is enabled. All other computers in Bldg 2 can ping/browse bldg 1.

Output of netstat -r:

$ netstat -r
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
localnet * U 0 0 0 eth0
localnet * U 0 0 0 wlan0
loopback * U 0 0 0 lo
default router UG 0 0 0 wlan0
default router UG 0 0 0 eth0

All computers, including laptop, have internet.

Following added to /etc/rc.d/rc.local:

iptables --table nat --append POSTROUTING --out-interface wlan0 -j MASQUERADE
iptables --append FORWARD --in-interface eth0 -j ACCEPT
echo 1 > /proc/sys/net/ipv4/ip_forward

If I disable eth0, I have total access to bldg 1.

Running Slackware 10.2, kernel 2.6.15