Find the answer to your Linux question:
Results 1 to 5 of 5
I can't get my sound to work. When I run "alsaconf", it doesn't detect any sound cards. I have both a "Creative Soundblaster Live" sound card, and onboard audio on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    2

    No sound?


    I can't get my sound to work. When I run "alsaconf", it doesn't detect any sound cards. I have both a "Creative Soundblaster Live" sound card, and onboard audio on an "Asus P4S8X" mobo. What can I do?



    Specs:

    OS: Slackware 10.2
    BootLoader: Lilo
    Desktop Environment: KDE on X
    Processor: P4 2.4Ghz
    RAM: 768 of DDR
    Hard Drive: 250GB SCSI equipped with 2 coolers
    Sound Cards: Creative Soundblaster Live, and Onboard Audio (Both mentioned above)

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Try recompiling the kernel with support for those cards enabled under Drivers -> Sound

  3. #3
    Just Joined!
    Join Date
    Jan 2006
    Location
    College Station, TX
    Posts
    37
    It doesn't list ANY sound cards when you run alsaconf?

    Which version of alsaconf are you running? Have you updated it?

    I have a Soundblaster Audigy 2 card and onboard sound. Whenever I install any Linux distro, I have to run alsaconf, select my Audigy 2 card (the onboard sound is always selected by default), turn on all of the switches in the mixer, and then restart the desktop before my sound works. After that< I have no problems.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2006
    Posts
    2
    I didn't compile the kernel, slackware did by itself.

  6. #5
    Just Joined!
    Join Date
    Jun 2005
    Posts
    72

    SW sound card

    Try taking out SB card and check that mob soundchip is enabled in BIOS. Lspci may help specify what sound chip is on board and what module/driver needed by alsa. Use onboard sound if that works.
    Alternatively turn off onboard sound in BIOS. Enabling or disabling plugnplay in BIOS may help. Install SB card. Review irqs and dma settings it requires. Kde control center or infocenter can list irqs and dmas in use and list sound card. See if SW detects it. Lspci or dmesg | less as root from cli or terminal. And try alsaconf again.
    www.slackwarebible.org/book/ 07. Multimedia entry will be useful for troubleshooting sound setup. Good luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •