Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
I would like to access my Windows hard drive (hda1) through my normal user account, but when I log in as root and try to change permissions for it, it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2006
    Location
    College Station, TX
    Posts
    37

    Can't access Windows hard drive through user account


    I would like to access my Windows hard drive (hda1) through my normal user account, but when I log in as root and try to change permissions for it, it comes up with a message saying that I can't change permissions for that drive. Can anyone help me fix this?

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    you can't change the windows drive perms though

    in your /etc/fstab , make sure you have 'user' in your options, this will allow it to be user mountable

    also, check the permissions on the mountpoint

    ls -lhd <mountpoint>

    change the perms and see if you can read after mounting

    chmod 777 <mountpoint>

  3. #3
    Just Joined!
    Join Date
    Jan 2006
    Location
    College Station, TX
    Posts
    37
    I tried doing what you suggested, but I still can't get it to work.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    what line is in your /etc/fstab for that partition?

    try unmounting the drive first

    what does ls -lhd <mountpount> return?

  6. #5
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    The Hot Humid South
    Posts
    602
    As far as I know, kern's method is the only way to do it.

    Unmount the drive, change permission of the mount point to 777, remount the drive!

    I tend to not have my Windows partition user mountable since I don't really want anyone unmount it once it's up (I have it to mount at boot time). If you want that capability, do as kern suggested and add a "user" option to fstab. Also make sure you're mount it "ro" (read-only).

  7. #6
    Just Joined!
    Join Date
    Jan 2006
    Location
    College Station, TX
    Posts
    37
    here's what my fstab file looks like after adding "user".

    /dev/hdb1 / ext3 defaults 1 1
    /dev/hda1 /ntfs-c ntfs ro,user 1 0
    /dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0
    /dev/fd0 /mnt/floppy auto noauto,owner 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    proc /proc proc defaults 0 0

    Here's what I get when I type "ls -lhd /ntfs-c" into the command line.

    dr-x------ 1 root root 8.0K 2006-02-05 18:06 /ntfs-c

    What am I doing wrong?

  8. #7
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    I do this in /etc/fstab to access my windows partitiion:-

    Code:
    /dev/hdc1           /mnt/dos            vfat    umask=0000,auto,noexec   0 0
    The partition, on my PC, is called /dev/hdc1, the mount point (folder) is called /mnt/dos and the umasc stuff (basically the binary revrese of a normal chmod) is the bit that allows free access.

    have fun

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  9. #8
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    type mount to see whats mounted,

    unmount the /ntfs-c partition, then

    chmod 777 /ntfs-c

    mount /ntsc-c

    do the permissions stay the same after mount? ro really isnt needed as NTFS write support is disabled by default anyway



    Quote Originally Posted by Mr_Tricorder
    here's what my fstab file looks like after adding "user".

    /dev/hdb1 / ext3 defaults 1 1
    /dev/hda1 /ntfs-c ntfs ro,user 1 0
    /dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0
    /dev/fd0 /mnt/floppy auto noauto,owner 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    proc /proc proc defaults 0 0

    Here's what I get when I type "ls -lhd /ntfs-c" into the command line.

    dr-x------ 1 root root 8.0K 2006-02-05 18:06 /ntfs-c

    What am I doing wrong?

  10. #9
    Just Joined!
    Join Date
    Jun 2005
    Posts
    72

    win hd in SW10.2

    Did you mkdir /ntfs-c? and chmod 660 ( or similar) /ntfs-c?
    Or did you setup the windows partition during install?
    Good luck.

  11. #10
    Just Joined!
    Join Date
    Jan 2006
    Location
    College Station, TX
    Posts
    37
    Quote Originally Posted by kern
    type mount to see whats mounted,

    unmount the /ntfs-c partition, then

    chmod 777 /ntfs-c

    mount /ntsc-c

    do the permissions stay the same after mount? ro really isnt needed as NTFS write support is disabled by default anyway
    The permissions stay the same.
    I didn't add "ro" to the fstab line. It was already there. All I did was add "user".

    Quote Originally Posted by lestoil
    Did you mkdir /ntfs-c? and chmod 660 ( or similar) /ntfs-c?
    Or did you setup the windows partition during install?
    Good luck.
    I set it up during the install.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •